aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/mickeyterm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/mickeyterm_git.bb')
-rw-r--r--recipes/freesmartphone/mickeyterm_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/freesmartphone/mickeyterm_git.bb b/recipes/freesmartphone/mickeyterm_git.bb
new file mode 100644
index 0000000000..276eeb55ab
--- /dev/null
+++ b/recipes/freesmartphone/mickeyterm_git.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Mickey's Terminal Program"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PV = "2.9.1+gitr${SRCREV}"
+PR = "r3"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mickeyterm/mickeyterm ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "\
+ python-readline \
+ python-pyserial \
+ python-textutils \
+ python-threading \
+"
+RRECOMMENDS_${PN} += "\
+ fso-gsm0710muxd \
+ python-dbus \
+"
+
+PACKAGE_ARCH_${PN} = "all"