aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/msmcommd_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/msmcommd_git.bb')
-rw-r--r--recipes/freesmartphone/msmcommd_git.bb32
1 files changed, 16 insertions, 16 deletions
diff --git a/recipes/freesmartphone/msmcommd_git.bb b/recipes/freesmartphone/msmcommd_git.bb
index bd74dc0f04..e8f3887c3a 100644
--- a/recipes/freesmartphone/msmcommd_git.bb
+++ b/recipes/freesmartphone/msmcommd_git.bb
@@ -1,20 +1,20 @@
-DESCRIPTION = "Low level protocol implementation for binary protocol spoken by some Qualcomm modems"
-HOMEPAGE = "http://www.freesmartphone.org"
-AUTHOR = "Simon Busch <morphis@gravedo.de>"
-SECTION = "console/network"
-LICENSE = "GPL"
-DEPENDS = "libgee libfsotransport gtk+"
-SRCREV = "91ea329fd3be68d031c61a587c6c0036b94cf2cd"
-PV = "0.1.0+gitr${SRCPV}"
-PR = "r2"
-PE = "1"
+require msmcomm.inc
-SRC_URI = "${FREESMARTPHONE_GIT}/msmcomm.git;protocol=git;branch=master"
-S = "${WORKDIR}/git"
+PR = "${INC_PR}.0"
+PV = "0.5.0+gitr${SRCPV}"
-inherit autotools vala
+DEPENDS = " \
+ vala-native \
+ glib-2.0 \
+ dbus \
+ dbus-glib \
+ libfso-glib \
+ libgee \
+ libmsmcomm \
+ msmcommd-specs \
+"
+
+S = "${WORKDIR}/git/msmcommd"
-PACKAGES =+ "${PN}-lib ${PN}-term"
-FILES_${PN}-lib = "${libdir}/lib*.so.*"
-FILES_${PN}-term = "${sbindir}/msmvterm"
+inherit autotools vala