aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/pylgrim_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/pylgrim_svn.bb')
-rw-r--r--recipes/freesmartphone/pylgrim_svn.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/freesmartphone/pylgrim_svn.bb b/recipes/freesmartphone/pylgrim_svn.bb
new file mode 100644
index 0000000000..beeb44c110
--- /dev/null
+++ b/recipes/freesmartphone/pylgrim_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A GPS moving map application featuring OpenStreetMap tiles"
+HOMEPAGE = "http://neo1973-germany.de/wiki/pylgrim"
+AUTHOR = "Josch"
+LICENSE = "GPL"
+SECTION = "x11/navigation"
+DEPENDS = "edje-native"
+RDEPENDS = "task-python-efl python-textutils"
+PV = "0.0+svnr${SRCREV}"
+PE = "1"
+
+SRC_URI = "svn://neo1973-germany.de/svn;module=pylgrim;proto=http"
+S = "${WORKDIR}/pylgrim"
+
+do_compile() {
+ edje_cc pylgrim.edc
+}
+
+do_install() {
+ install -d ${D}${datadir}/pylgrim
+ for i in *.py pylgrim.edj; do
+ install -m 0755 $i ${D}${datadir}/pylgrim/
+ done
+}
+
+FILES_${PN} += "${datadir}"