aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/cornucopia.inc5
-rw-r--r--recipes/freesmartphone/frameworkd_git.bb4
-rw-r--r--recipes/freesmartphone/fso-abyss_git.bb15
-rw-r--r--recipes/freesmartphone/fso-alsa_git.bb17
-rw-r--r--recipes/freesmartphone/fso-apm_git.bb11
-rw-r--r--recipes/freesmartphone/fso-monitord_git.bb4
-rw-r--r--recipes/freesmartphone/fso-specs_git.bb6
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb8
-rw-r--r--recipes/freesmartphone/fsogsmd_git.bb11
-rw-r--r--recipes/freesmartphone/fsoinitd_git.bb13
-rw-r--r--recipes/freesmartphone/fsonetworkd_git.bb3
-rw-r--r--recipes/freesmartphone/fsoraw_git.bb18
-rw-r--r--recipes/freesmartphone/fsoraw_svn.bb6
-rw-r--r--recipes/freesmartphone/libframeworkd-glib_git.bb2
-rw-r--r--recipes/freesmartphone/libfso-glib_git.bb13
-rw-r--r--recipes/freesmartphone/libgsm0710_git.bb2
-rw-r--r--recipes/freesmartphone/libgsm0710mux_git.bb9
-rw-r--r--recipes/freesmartphone/libpersistence_git.bb2
-rw-r--r--recipes/freesmartphone/mdbus2_git.bb14
-rw-r--r--recipes/freesmartphone/mdbus_git.bb9
-rw-r--r--recipes/freesmartphone/mickeyterm_git.bb9
-rw-r--r--recipes/freesmartphone/mioctl_git.bb4
-rw-r--r--recipes/freesmartphone/mkdump_git.bb15
-rw-r--r--recipes/freesmartphone/msmcommd_git.bb6
-rw-r--r--recipes/freesmartphone/mterm2_git.bb15
-rw-r--r--recipes/freesmartphone/multicat_git.bb9
-rw-r--r--recipes/freesmartphone/opimd-utils_git.bb2
-rw-r--r--recipes/freesmartphone/pycd_git.bb7
-rw-r--r--recipes/freesmartphone/python-helpers.inc8
-rw-r--r--recipes/freesmartphone/zhone2_git.bb4
30 files changed, 135 insertions, 116 deletions
diff --git a/recipes/freesmartphone/cornucopia.inc b/recipes/freesmartphone/cornucopia.inc
index 4962263a10..11cbdd3b78 100644
--- a/recipes/freesmartphone/cornucopia.inc
+++ b/recipes/freesmartphone/cornucopia.inc
@@ -1,16 +1,19 @@
DESCRIPTION = "The freesmartphone.org API reference implementation (FSO 2.0)"
AUTHOR = "Team FSO"
+HOMEPAGE = "http://www.freesmartphone.org"
LICENSE = "LGPL"
SECTION = "devel"
DEPENDS = "vala-native glib-2.0 dbus dbus-glib libfso-glib libgee"
DEPENDS += "${@['libfsoframework', ''][(bb.data.getVar('PN', d, 1) in 'libfsoframework libfsobasics'.split())]}"
PV = "invalid, please override"
+
+FSO_CORNUCOPIA_SRCREV ?= "38d52c14a09dd7afc22048f2ed278e336f42a933"
INC_PR = "r2"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia;protocol=git;branch=master"
S = "${WORKDIR}/git/${PN}"
-inherit autotools_stage pkgconfig vala
+inherit autotools pkgconfig vala
FILES_${PN} += "\
${sysconfdir} \
diff --git a/recipes/freesmartphone/frameworkd_git.bb b/recipes/freesmartphone/frameworkd_git.bb
index 2b6b0bba64..395a137156 100644
--- a/recipes/freesmartphone/frameworkd_git.bb
+++ b/recipes/freesmartphone/frameworkd_git.bb
@@ -4,7 +4,7 @@ AUTHOR = "FreeSmartphone.Org Development Team"
SECTION = "console/network"
DEPENDS = "python-cython-native python-pyrex-native"
LICENSE = "GPL"
-SRCREV = "f751f2724eea23d0ca050bdf2672f9011ae09517"
+SRCREV = "93673aa09cafc8fb5cfc3cb4055a73e25e595b70"
PV = "0.9.5.9+gitr${SRCPV}"
PR = "r3"
PE = "1"
@@ -18,7 +18,7 @@ SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=master \
file://frameworkd \
file://frameworkd.conf \
"
-SRC_URI_append_shr = "file://oeventsd-use-opimd-signals.patch;patch=1"
+SRC_URI_append_shr = "file://oeventsd-use-opimd-signals.patch"
S = "${WORKDIR}/git"
diff --git a/recipes/freesmartphone/fso-abyss_git.bb b/recipes/freesmartphone/fso-abyss_git.bb
index c23bbf457b..b052e88202 100644
--- a/recipes/freesmartphone/fso-abyss_git.bb
+++ b/recipes/freesmartphone/fso-abyss_git.bb
@@ -1,21 +1,18 @@
+require cornucopia.inc
+
DESCRIPTION = "Abyss is a GSM 07.10 muxer userspace daemon"
HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/Abyss"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
SECTION = "console/network"
-DEPENDS = "vala-native dbus dbus-glib libgsm0710mux"
+DEPENDS = "dbus dbus-glib libgsm0710mux"
LICENSE = "GPL"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.9.2+gitr${SRCPV}"
PE = "1"
-PR = "r1"
-
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master \
- file://fso-abyss.conf \
-"
-S = "${WORKDIR}/git/tools/fso-abyss"
+PR = "${INC_PR}.0"
-inherit autotools_stage
+SRC_URI += " file://fso-abyss.conf"
+S = "${WORKDIR}/git/tools/${PN}"
do_install_append() {
install -d ${D}${sysconfdir}
diff --git a/recipes/freesmartphone/fso-alsa_git.bb b/recipes/freesmartphone/fso-alsa_git.bb
index 8f5e173bdd..77261726bc 100644
--- a/recipes/freesmartphone/fso-alsa_git.bb
+++ b/recipes/freesmartphone/fso-alsa_git.bb
@@ -1,18 +1,13 @@
+require cornucopia.inc
+
DESCRIPTION = "Mickey's DBus introspection and calling Program V2"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/multimedia"
LICENSE = "GPLv2"
DEPENDS = "fsodeviced glib-2.0 dbus dbus-glib"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
-PV = "1.0.0+gitr${SRCREV}"
-PR = "r0"
-
-SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
-S = "${WORKDIR}/git/tools/fso-alsa"
-
-do_stage() {
- :
-}
+PV = "1.0.0+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+PE = "1"
-inherit autotools_stage vala
+S = "${WORKDIR}/git/tools/${PN}"
diff --git a/recipes/freesmartphone/fso-apm_git.bb b/recipes/freesmartphone/fso-apm_git.bb
index a42492f0f0..004786028e 100644
--- a/recipes/freesmartphone/fso-apm_git.bb
+++ b/recipes/freesmartphone/fso-apm_git.bb
@@ -1,18 +1,13 @@
+require cornucopia.inc
+
DESCRIPTION = "freesmartphone.org apm compatibility utility"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console"
LICENSE = "GPLv2"
PE = "1"
-DEPENDS = "vala-native"
RCONFLICTS = "apm"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "2.0.0+gitr${SRCPV}"
-PR = "r1"
+PR = "${INC_PR}.0"
-SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
S = "${WORKDIR}/git/tools/apm2"
-
-inherit autotools
-
-
diff --git a/recipes/freesmartphone/fso-monitord_git.bb b/recipes/freesmartphone/fso-monitord_git.bb
index 0c931bdad0..808a17f1ba 100644
--- a/recipes/freesmartphone/fso-monitord_git.bb
+++ b/recipes/freesmartphone/fso-monitord_git.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "freesmartphone.org monitor daemon"
AUTHOR = "freesmartphone.org development team"
SECTION = "console/network"
-DEPENDS = "vala-native dbus dbus-glib"
+DEPENDS = "vala dbus dbus-glib"
LICENSE = "GPL"
SRCREV = "b4ae1e9b10e710042624c2cf1a15b91a7d5b1d44"
PV = "0.0.0+gitr${SRCPV}"
@@ -11,7 +11,7 @@ PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/fso-monitord.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
-inherit autotools update-rc.d
+inherit autotools update-rc.d vala
INITSCRIPT_NAME = "fso-monitord"
INITSCRIPT_PARAMS = "defaults 35"
diff --git a/recipes/freesmartphone/fso-specs_git.bb b/recipes/freesmartphone/fso-specs_git.bb
index 045ae34f9f..a003637fa9 100644
--- a/recipes/freesmartphone/fso-specs_git.bb
+++ b/recipes/freesmartphone/fso-specs_git.bb
@@ -4,10 +4,9 @@ HOMEPAGE = "http://docs.freesmartphone.org"
LICENSE = "BSD"
DEPENDS = "libxslt-native"
SECTION = "devel/specifications"
-SRCREV = "1dd28e0a716c10564b3b1c6f5c696e7afa19bff6"
-PV = "0.5.0+gitr${SRCPV}"
+SRCREV = "5e5c9b52e7525085f0d8601861d712f05523ad0a"
+PV = "2010.05.11.2+gitr${SRCPV}"
PE = "1"
-PR = "r2"
SRC_URI = "${FREESMARTPHONE_GIT}/specs.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
@@ -15,7 +14,6 @@ S = "${WORKDIR}/git"
inherit autotools pkgconfig
FILES_${PN}-dev += "${datadir}/freesmartphone/xml"
-PACKAGE_ARCH = "all"
do_compile_append() {
sed -i -e s,\$\{datarootdir\},${STAGING_DATADIR},g *.pc
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 1e1f73e710..e7ea1c0a6a 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -9,7 +9,7 @@ RPROVIDES_${PN} = "openmoko-alsa-scenarios virtual/alsa-scenarios"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.9.0+gitr${SRCPV}"
PE = "2"
-PR = "${INC_PR}.11"
+PR = "${INC_PR}.12"
EXTRA_OECONF = "\
--enable-kernel26-rfkill \
@@ -23,6 +23,12 @@ INITSCRIPT_PARAMS = "defaults 27"
SRC_URI += "file://fsodeviced"
+CONFFILES_${PN} = "${sysconfdir}/freesmartphone/conf/openmoko_gta/fsodeviced.conf \
+ ${sysconfdir}/freesmartphone/conf/palm_pre/fsodeviced.conf \
+ ${sysconfdir}/freesmartphone/conf/htc_qualcomm_dream/fsodeviced.conf \
+ ${sysconfdir}/freesmartphone/conf/htc_qualcomm_msm/fsodeviced.conf \
+ "
+
do_install_append() {
install -d ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/fsodeviced ${D}${sysconfdir}/init.d/
diff --git a/recipes/freesmartphone/fsogsmd_git.bb b/recipes/freesmartphone/fsogsmd_git.bb
index d331f312f1..e2cbd53e27 100644
--- a/recipes/freesmartphone/fsogsmd_git.bb
+++ b/recipes/freesmartphone/fsogsmd_git.bb
@@ -1,7 +1,7 @@
require cornucopia.inc
inherit fso-plugin
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.2"
PV = "0.5.0+gitr${SRCPV}"
PE = "1"
@@ -12,7 +12,8 @@ EXTRA_OECONF_append = "\
--enable-modem-qualcomm-palm \
"
-do_install_append_shr() {
- # remove .service file to disable fsogsmd autostart
- rm -f ${D}${datadir}/dbus-1/system-services/org.freesmartphone.ogsmd.service
-}
+CONFFILES_${PN} = "${sysconfdir}/freesmartphone/conf/openmoko_gta/fsogsmd.conf \
+ ${sysconfdir}/freesmartphone/conf/palm_pre/fsogsmd.conf \
+ ${sysconfdir}/freesmartphone/conf/htc_qualcomm_dream/fsogsmd.conf \
+ ${sysconfdir}/freesmartphone/conf/htc_qualcomm_msm/fsogsmd.conf \
+ "
diff --git a/recipes/freesmartphone/fsoinitd_git.bb b/recipes/freesmartphone/fsoinitd_git.bb
new file mode 100644
index 0000000000..dfb0b94f86
--- /dev/null
+++ b/recipes/freesmartphone/fsoinitd_git.bb
@@ -0,0 +1,13 @@
+require cornucopia.inc
+inherit fso-plugin
+
+SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "${INC_PR}.1"
+
+EXTRA_OECONF = ""
+EXTRA_OECONF_append_palmpre = "--with-machine=palmpre"
+EXTRA_OECONF_append_om-gta02 = "--with-machine=om-gta02"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
diff --git a/recipes/freesmartphone/fsonetworkd_git.bb b/recipes/freesmartphone/fsonetworkd_git.bb
index e64de8e96d..974ac3ccc7 100644
--- a/recipes/freesmartphone/fsonetworkd_git.bb
+++ b/recipes/freesmartphone/fsonetworkd_git.bb
@@ -3,4 +3,5 @@ inherit fso-plugin
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.1.0.0+gitr${SRCPV}"
PE = "1"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
+RDEPENDS += "iptables"
diff --git a/recipes/freesmartphone/fsoraw_git.bb b/recipes/freesmartphone/fsoraw_git.bb
new file mode 100644
index 0000000000..d16811b03a
--- /dev/null
+++ b/recipes/freesmartphone/fsoraw_git.bb
@@ -0,0 +1,18 @@
+require cornucopia.inc
+
+DESCRIPTION = "A console wrapper for the FSO Usage API"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+SECTION = "fso/base"
+LICENSE = "GPLv2"
+SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
+PV = "1.0.0+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+PE = "1"
+
+S = "${WORKDIR}/git/tools/fso-raw"
+
+# for backward compatibility in scripts
+do_install_append() {
+ install -d ${D}${bindir}
+ ln -s fso-raw ${D}${bindir}/fsoraw
+}
diff --git a/recipes/freesmartphone/fsoraw_svn.bb b/recipes/freesmartphone/fsoraw_svn.bb
index 74b1274782..f10f2212f0 100644
--- a/recipes/freesmartphone/fsoraw_svn.bb
+++ b/recipes/freesmartphone/fsoraw_svn.bb
@@ -12,3 +12,9 @@ SRC_URI = "svn://noko.svn.sourceforge.net/svnroot/noko/trunk;module=fsoraw;proto
S = "${WORKDIR}/fsoraw/"
inherit autotools
+
+# for forward compatibility in scripts
+do_install_append() {
+ install -d ${D}${bindir}
+ ln -s fsoraw ${D}${bindir}/fso-raw
+}
diff --git a/recipes/freesmartphone/libframeworkd-glib_git.bb b/recipes/freesmartphone/libframeworkd-glib_git.bb
index 5fa47d835f..15ef006273 100644
--- a/recipes/freesmartphone/libframeworkd-glib_git.bb
+++ b/recipes/freesmartphone/libframeworkd-glib_git.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "freesmartphone.org API glib wrapper"
LICENSE = "LGPL"
SECTION = "devel"
DEPENDS = "dbus-glib"
-SRCREV = "66eab3e4c444f161497268953b47192a2d7c80bc"
+SRCREV = "43f25d7343145111e70dceaa610decab84366cbb"
PV = "0.0.1+gitr${SRCPV}"
PE = "1"
PR = "r0"
diff --git a/recipes/freesmartphone/libfso-glib_git.bb b/recipes/freesmartphone/libfso-glib_git.bb
index 8984741be7..dad6c002dd 100644
--- a/recipes/freesmartphone/libfso-glib_git.bb
+++ b/recipes/freesmartphone/libfso-glib_git.bb
@@ -2,17 +2,12 @@ DESCRIPTION = "GLib-based DBus bindings for freesmartphone.org - Vala implementa
AUTHOR = "Didier 'Ptitjes"
LICENSE = "LGPL"
SECTION = "devel"
-DEPENDS = "vala-native vala-dbus-binding-tool-native dbus-glib glib-2.0 fso-specs"
-SRCREV = "f1a0b3fe2ed6e15d83ad4880b4eb7aece00f9d57"
-PV = "0.2.2+gitr${SRCPV}"
+DEPENDS = "vala-dbus-binding-tool-native dbus-glib glib-2.0 fso-specs"
+SRCREV = "5cda3952855d6c4273929449339b04509387bdd2"
+PV = "2010.05.11.2+gitr${SRCPV}"
PE = "1"
-PR = "r4"
-inherit autotools_stage pkgconfig vala
-
-PARALLEL_MAKE = ""
+inherit autotools vala
SRC_URI = "${FREESMARTPHONE_GIT}/libfso-glib.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
-
-FILES_${PN}-dev += "${datadir}/gir-1.0/*.gir"
diff --git a/recipes/freesmartphone/libgsm0710_git.bb b/recipes/freesmartphone/libgsm0710_git.bb
index 6b78c9f922..2c78789d9b 100644
--- a/recipes/freesmartphone/libgsm0710_git.bb
+++ b/recipes/freesmartphone/libgsm0710_git.bb
@@ -9,4 +9,4 @@ PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/libgsm0710.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
-inherit autotools_stage pkgconfig vala
+inherit autotools vala
diff --git a/recipes/freesmartphone/libgsm0710mux_git.bb b/recipes/freesmartphone/libgsm0710mux_git.bb
index f85be3c238..4c791d70e2 100644
--- a/recipes/freesmartphone/libgsm0710mux_git.bb
+++ b/recipes/freesmartphone/libgsm0710mux_git.bb
@@ -1,3 +1,5 @@
+require cornucopia.inc
+
DESCRIPTION = "A GSM 07.10 Multiplexing Engine"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
LICENSE = "GPL"
@@ -6,9 +8,4 @@ DEPENDS = "glib-2.0 libgsm0710 libfsotransport"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.9.2+gitr${SRCPV}"
PE = "1"
-PR = "r0"
-
-SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
-S = "${WORKDIR}/git/libgsm0710mux"
-
-inherit autotools_stage pkgconfig vala
+PR = "${INC_PR}.0"
diff --git a/recipes/freesmartphone/libpersistence_git.bb b/recipes/freesmartphone/libpersistence_git.bb
index 0550045aed..ab1892e246 100644
--- a/recipes/freesmartphone/libpersistence_git.bb
+++ b/recipes/freesmartphone/libpersistence_git.bb
@@ -13,4 +13,4 @@ SRC_URI = "\
"
S = "${WORKDIR}/git"
-inherit autotools_stage pkgconfig vala
+inherit autotools vala
diff --git a/recipes/freesmartphone/mdbus2_git.bb b/recipes/freesmartphone/mdbus2_git.bb
index 76af519d4b..cfa6ef3698 100644
--- a/recipes/freesmartphone/mdbus2_git.bb
+++ b/recipes/freesmartphone/mdbus2_git.bb
@@ -1,19 +1,13 @@
+require cornucopia.inc
+
DESCRIPTION = "Mickey's DBus introspection and calling Program V2"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
LICENSE = "GPLv2"
DEPENDS = "glib-2.0 dbus dbus-glib"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "2.0.0+gitr${SRCPV}"
-PR = "r0"
+PR = "${INC_PR}.0"
PE = "1"
-SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
-S = "${WORKDIR}/git/tools/mdbus2"
-
-do_stage() {
- :
-}
-
-inherit autotools_stage vala
+S = "${WORKDIR}/git/tools/${PN}"
diff --git a/recipes/freesmartphone/mdbus_git.bb b/recipes/freesmartphone/mdbus_git.bb
index f90fd7eb8c..14a676e017 100644
--- a/recipes/freesmartphone/mdbus_git.bb
+++ b/recipes/freesmartphone/mdbus_git.bb
@@ -1,16 +1,13 @@
DESCRIPTION = "Mickey's DBus introspection and calling Program"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
-LICENSE = "GPLv2"
+
+require python-helpers.inc
+
SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
PV = "0.9.2+gitr${SRCPV}"
-PE = "1"
PR = "r2"
-SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
-S = "${WORKDIR}/git"
-
do_install() {
install -d ${D}${bindir}
install -m 0755 mickeydbus/mdbus ${D}${bindir}
diff --git a/recipes/freesmartphone/mickeyterm_git.bb b/recipes/freesmartphone/mickeyterm_git.bb
index 20730218f1..41b5636625 100644
--- a/recipes/freesmartphone/mickeyterm_git.bb
+++ b/recipes/freesmartphone/mickeyterm_git.bb
@@ -1,16 +1,13 @@
DESCRIPTION = "Mickey's Terminal Program"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
-LICENSE = "GPLv2"
+
+require python-helpers.inc
+
SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
PV = "2.9.1+gitr${SRCPV}"
-PE = "1"
PR = "r3"
-SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
-S = "${WORKDIR}/git"
-
do_install() {
install -d ${D}${bindir}
install -m 0755 mickeyterm/mickeyterm ${D}${bindir}
diff --git a/recipes/freesmartphone/mioctl_git.bb b/recipes/freesmartphone/mioctl_git.bb
index 56bb1c42af..e09c424b51 100644
--- a/recipes/freesmartphone/mioctl_git.bb
+++ b/recipes/freesmartphone/mioctl_git.bb
@@ -10,8 +10,4 @@ PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
S = "${WORKDIR}/git/tools/mioctl"
-do_stage() {
- :
-}
-
inherit autotools vala
diff --git a/recipes/freesmartphone/mkdump_git.bb b/recipes/freesmartphone/mkdump_git.bb
new file mode 100644
index 0000000000..d3171bbd2c
--- /dev/null
+++ b/recipes/freesmartphone/mkdump_git.bb
@@ -0,0 +1,15 @@
+require cornucopia.inc
+
+DESCRIPTION = "mkdump is a kernel message dumper"
+HOMEPAGE = "http://www.freesmartphone.org/index.php/Implementations/mkdump"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+SECTION = "console/network"
+DEPENDS = "libfsoframework"
+LICENSE = "GPL"
+
+#SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
+SRCREV = "696d93d7146adffdb76ddb951a7d8199b3dc8a81"
+PV = "1.0.0+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+
+S = "${WORKDIR}/git/tools/${PN}"
diff --git a/recipes/freesmartphone/msmcommd_git.bb b/recipes/freesmartphone/msmcommd_git.bb
index 7177e50fc1..e1f69bbbf4 100644
--- a/recipes/freesmartphone/msmcommd_git.bb
+++ b/recipes/freesmartphone/msmcommd_git.bb
@@ -4,7 +4,7 @@ AUTHOR = "Simon Busch <morphis@gravedo.de>"
SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "libgee libfsotransport"
-SRCREV = "23c0cd870fc989792a20c6c662db4400129bd471"
+SRCREV = "cdbb26ba215cf314cf8ccf25a5e7cbdcb9f7bece"
PV = "0.1.0+gitr${SRCPV}"
PR = "r2"
PE = "1"
@@ -12,9 +12,7 @@ PE = "1"
SRC_URI = "${FREESMARTPHONE_GIT}/msmcomm.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
-inherit autotools_stage vala
-
-PARALLEL_MAKE = ""
+inherit autotools vala
PACKAGES =+ "${PN}-lib ${PN}-term"
FILES_${PN}-lib = "${libdir}/lib*.so.*"
diff --git a/recipes/freesmartphone/mterm2_git.bb b/recipes/freesmartphone/mterm2_git.bb
index f459a4ab65..8615af7678 100644
--- a/recipes/freesmartphone/mterm2_git.bb
+++ b/recipes/freesmartphone/mterm2_git.bb
@@ -1,3 +1,5 @@
+require cornucopia.inc
+
DESCRIPTION = "mterm is a versatile muxer-aware terminal program"
HOMEPAGE = "http://www.freesmartphone.org/index.php/Implementations/fso-term"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
@@ -7,17 +9,8 @@ LICENSE = "GPL"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.1.0+gitr${SRCPV}"
PE = "1"
-PR = "r0"
-
-SRC_URI = "\
- ${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master \
-"
-S = "${WORKDIR}/git/tools/mterm2"
-
-do_stage() {
- :
-}
+PR = "${INC_PR}.0"
-inherit autotools vala
+S = "${WORKDIR}/git/tools/${PN}"
FILES_${PN} += "${datadir}"
diff --git a/recipes/freesmartphone/multicat_git.bb b/recipes/freesmartphone/multicat_git.bb
index a47f6056e0..77d61159b3 100644
--- a/recipes/freesmartphone/multicat_git.bb
+++ b/recipes/freesmartphone/multicat_git.bb
@@ -1,16 +1,13 @@
DESCRIPTION = "Multiple cat utility"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console"
-LICENSE = "GPLv2"
+
+require python-helpers.inc
+
SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
PV = "0.0.0+gitr${SRCPV}"
-PE = "1"
PR = "r1"
-SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
-S = "${WORKDIR}/git"
-
do_install() {
install -d ${D}${bindir}
install -m 0755 multicat/multicat ${D}${bindir}
diff --git a/recipes/freesmartphone/opimd-utils_git.bb b/recipes/freesmartphone/opimd-utils_git.bb
index 79a44ae6ff..446cc059bb 100644
--- a/recipes/freesmartphone/opimd-utils_git.bb
+++ b/recipes/freesmartphone/opimd-utils_git.bb
@@ -4,7 +4,7 @@ SHR_RELEASE ?= "shr"
LICENSE ?= "GPL"
RDEPENDS = "python-elementary python-dbus python-codecs python-shell python python-core python-edbus frameworkd"
SECTION = "x11/application"
-SRCREV = "1872cdebe1209123710259e25cb8c8b47a627112"
+SRCREV = "5618e320f5380a51c43e0aebeb0783c976c3091f"
PV = "0.0.3+gitr${SRCPV}"
PR = "r0"
PE = "1"
diff --git a/recipes/freesmartphone/pycd_git.bb b/recipes/freesmartphone/pycd_git.bb
index 92b0bb951d..eebc11c0a0 100644
--- a/recipes/freesmartphone/pycd_git.bb
+++ b/recipes/freesmartphone/pycd_git.bb
@@ -1,14 +1,13 @@
DESCRIPTION = "Python Clone Factory"
AUTHOR = "Jan Luebbe <jluebbe@debian.org>"
-HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "console/network"
-LICENSE = "GPLv2"
+
+require python-helpers.inc
+
SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
PV = "0.1+gitr${SRCPV}"
-PE = "1"
PR = "r0"
-SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
S = "${WORKDIR}/git/${PN}"
RDEPENDS_${PN} = "\
diff --git a/recipes/freesmartphone/python-helpers.inc b/recipes/freesmartphone/python-helpers.inc
new file mode 100644
index 0000000000..4397627e6d
--- /dev/null
+++ b/recipes/freesmartphone/python-helpers.inc
@@ -0,0 +1,8 @@
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PE = "1"
+
+FSO_PYTHONHELPERS_SRCREV ?= "63b1dff1bc8ac22efabcee8a90e957c3b2423317"
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
diff --git a/recipes/freesmartphone/zhone2_git.bb b/recipes/freesmartphone/zhone2_git.bb
index 11402b4649..440b922dac 100644
--- a/recipes/freesmartphone/zhone2_git.bb
+++ b/recipes/freesmartphone/zhone2_git.bb
@@ -3,7 +3,7 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "x11"
LICENSE = "GPLv2"
-DEPENDS = "edje-native vala-native evas ecore edje libeflvala libfsobasics libfsoframework libfso-glib"
+DEPENDS = "edje-native evas ecore edje libeflvala libfsobasics libfsoframework libfso-glib"
SRCREV = "1e3dca8a407f4e69636c47d9f22b31f8ae718d5a"
PV = "2.0.0+gitr${SRCPV}"
PR = "r2"
@@ -18,7 +18,7 @@ SRC_URI[splash.md5sum] = "e198d5c83cc47a216562e435df0e03c3"
SRC_URI[splash.sha256sum] = "3e41bcf4ea50ab7406d3833e412a78ddb9afaab4b0a8cca1bf93755d1ce9a215"
S = "${WORKDIR}/git/zhone2"
-inherit autotools_stage update-rc.d
+inherit autotools update-rc.d vala
INITSCRIPT_NAME = "zhone2"
INITSCRIPT_PARAMS = "defaults 40"