summaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb b/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb
new file mode 100644
index 0000000000..3076f9501c
--- /dev/null
+++ b/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Vala DBus Binding Tool"
+SECTION = "console"
+LICENSE = "GPLv2"
+DEPENDS = "vala-native"
+PV = "0.1.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/vala-dbus-binding-tool.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools native
+
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 src/vala-dbus-binding-tool ${STAGING_BINDIR_NATIVE}/
+}
+