aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/frozen-bubble/frozen-bubble_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/frozen-bubble/frozen-bubble_1.0.0.bb')
-rw-r--r--recipes/frozen-bubble/frozen-bubble_1.0.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/frozen-bubble/frozen-bubble_1.0.0.bb b/recipes/frozen-bubble/frozen-bubble_1.0.0.bb
new file mode 100644
index 0000000000..503c4c7a7d
--- /dev/null
+++ b/recipes/frozen-bubble/frozen-bubble_1.0.0.bb
@@ -0,0 +1,19 @@
+LICENSE = "GPL"
+SECTION = "games"
+DEPENDS = "libsdl-mixer libsdl-image sdl-perl"
+
+SRC_URI = "http://zarb.org/~gc/fb//frozen-bubble-${PV}.tar.bz2 \
+ file://Makefile_top.patch;patch=1 \
+ file://Makefile.patch;patch=1 \
+ file://Makefile.PL.patch;patch=1"
+# The Makefile needs to be patched to look in STAGING_LIBDIR/perl/... - It's looking in i686-linux/lib at the moment, regardless of arch
+BROKEN = "1"
+
+
+do_compile() {
+ oe_runmake OPTIMIZE="${CFLAGS}" PREFIX="${prefix}"
+}
+
+do_install() {
+ oe_runmake PREFIX="${D}${prefix}" install
+}