aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fxload
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fxload')
-rw-r--r--recipes/fxload/files/usbheader.patch15
-rw-r--r--recipes/fxload/fxload_0.0.20020411.bb19
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes/fxload/files/usbheader.patch b/recipes/fxload/files/usbheader.patch
new file mode 100644
index 0000000000..db205e9ab5
--- /dev/null
+++ b/recipes/fxload/files/usbheader.patch
@@ -0,0 +1,15 @@
+--- fxload-0.0.20020411.orig/ezusb.c
++++ fxload-0.0.20020411/ezusb.c
+@@ -29,7 +29,11 @@
+ # include <sys/ioctl.h>
+
+ # include <linux/version.h>
+-# include <linux/usb.h>
++#if (LINUX_VERSION_CODE >= 132630)
++# include <linux/usb/ch9.h>
++#else
++# include <linux/usb_ch9.h>
++#endif
+ # include <linux/usbdevice_fs.h>
+
+ # include "ezusb.h"
diff --git a/recipes/fxload/fxload_0.0.20020411.bb b/recipes/fxload/fxload_0.0.20020411.bb
new file mode 100644
index 0000000000..2bebded964
--- /dev/null
+++ b/recipes/fxload/fxload_0.0.20020411.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "fxload loads firmware into the ezusb chips"
+AUTHOR = "Stephen Williams, David Brownell"
+HOMEPAGE = "http://linux-hotplug.sourceforge.net/"
+SECTION = "admin"
+LICENSE = "GPL"
+DEPENDS = "linux-libc-headers"
+PR = "r1"
+
+SRC_URI = "http://dfn.dl.sourceforge.net/sourceforge/linux-hotplug/fxload-2002_04_11.tar.gz \
+ file://usbheader.patch;patch=1"
+
+S = "${WORKDIR}/fxload-2002_04_11"
+
+FILES_${PN} = "${base_sbindir}/fxload"
+
+do_install() {
+ mkdir -p ${D}/sbin/
+ cp ${S}/fxload ${D}/sbin/fxload
+}