aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gal/gal-2.1_2.1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gal/gal-2.1_2.1.10.bb')
-rw-r--r--recipes/gal/gal-2.1_2.1.10.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/gal/gal-2.1_2.1.10.bb b/recipes/gal/gal-2.1_2.1.10.bb
new file mode 100644
index 0000000000..b4e958b86a
--- /dev/null
+++ b/recipes/gal/gal-2.1_2.1.10.bb
@@ -0,0 +1,21 @@
+LICENSE = "GPL"
+SECTION = "x11/libs"
+DEPENDS = "intltool libgnomeprint gtk+ libglade libgnomeui libgnomecanvas libxml2 libgnomeprintui"
+
+inherit gnome
+
+SRC_URI = "${GNOME_MIRROR}/gal/2.1/gal-${PV}.tar.bz2 \
+ file://configure.patch;patch=1 \
+ file://forward-decl.patch;patch=1 \
+ file://iconv-detect.h"
+
+S = "${WORKDIR}/gal-${PV}"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/iconv-detect.h ${S}/
+}
+
+do_stage() {
+ gnome_stage_includes
+ oe_libinstall -C gal -so -a libgal-2.2 ${STAGING_LIBDIR}
+}