aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcalctool
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcalctool')
-rw-r--r--recipes/gcalctool/gcalctool/makefile-fix.diff18
-rw-r--r--recipes/gcalctool/gcalctool/noscrollkeeper.patch18
-rw-r--r--recipes/gcalctool/gcalctool_5.5.21.bb18
-rw-r--r--recipes/gcalctool/gcalctool_5.7.32.bb12
4 files changed, 66 insertions, 0 deletions
diff --git a/recipes/gcalctool/gcalctool/makefile-fix.diff b/recipes/gcalctool/gcalctool/makefile-fix.diff
new file mode 100644
index 0000000000..48a546271f
--- /dev/null
+++ b/recipes/gcalctool/gcalctool/makefile-fix.diff
@@ -0,0 +1,18 @@
+--- gcalctool/Makefile.am~ 2005-03-23 16:50:10.000000000 +0000
++++ gcalctool/Makefile.am 2006-03-20 13:59:17.000000000 +0000
+@@ -30,15 +30,8 @@
+
+ SCHEMAS_FILE = gcalctool.schemas
+
+-### Install the schemas file in /etc if GNOME support is not compiled in,
+-### and do not install the schemas at all
+-if DISABLE_GNOME
+-schemasdir = $(sysconfdir)/gcalctool
+-schemas_DATA = $(SCHEMAS_FILE)
+-else
+ schemadir = $(GCONF_SCHEMA_FILE_DIR)
+ schema_DATA = $(SCHEMAS_FILE)
+-endif
+
+ EXTRA_DIST = \
+ autogen.sh \
diff --git a/recipes/gcalctool/gcalctool/noscrollkeeper.patch b/recipes/gcalctool/gcalctool/noscrollkeeper.patch
new file mode 100644
index 0000000000..1f36762460
--- /dev/null
+++ b/recipes/gcalctool/gcalctool/noscrollkeeper.patch
@@ -0,0 +1,18 @@
+--- gcalctool-5.5.21/configure.in 2004-12-21 11:06:24.000000000 -0700
++++ gcalctool-5.5.21.new/configure.in 2005-01-04 16:25:32.179108536 -0700
+@@ -42,15 +42,6 @@
+ AC_SUBST(GCONF_CFLAGS)
+ AC_SUBST(GCONF_LIBS)
+
+-dnl ********************
+-dnl scrollkeeper checks
+-dnl ********************
+-
+-AC_PATH_PROG(SCROLLKEEPER_CONFIG, scrollkeeper-config,no)
+-if test x$SCROLLKEEPER_CONFIG = xno; then
+- AC_MSG_ERROR(Couldn't find scrollkeeper-config. Please install the scrollkeeper package)
+-fi
+-
+ dnl *******************************
+ dnl Internationalization
+ dnl *******************************
diff --git a/recipes/gcalctool/gcalctool_5.5.21.bb b/recipes/gcalctool/gcalctool_5.5.21.bb
new file mode 100644
index 0000000000..ef16f09b46
--- /dev/null
+++ b/recipes/gcalctool/gcalctool_5.5.21.bb
@@ -0,0 +1,18 @@
+# gcalctool OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+LICENSE = "GPL"
+SECTION = "x11/utils"
+
+inherit gnome
+
+DEPENDS = "gnome-common gtk+ libgnomeui"
+
+EXTRA_OECONF = "--disable-schemas-install"
+
+SRC_URI += "file://noscrollkeeper.patch;patch=1"
+
+do_configure_prepend () {
+ cp ${STAGING_DATADIR}/gnome-common/data/omf.make ${S}
+}
diff --git a/recipes/gcalctool/gcalctool_5.7.32.bb b/recipes/gcalctool/gcalctool_5.7.32.bb
new file mode 100644
index 0000000000..084b5e4c82
--- /dev/null
+++ b/recipes/gcalctool/gcalctool_5.7.32.bb
@@ -0,0 +1,12 @@
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "gtk+"
+DESCRIPTION = "gcalctool is a powerful calculator"
+PR = "r1"
+
+SRC_URI = "http://download.gnome.org/sources/${PN}/5.7/${PN}-${PV}.tar.gz \
+ file://makefile-fix.diff;patch=1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gnome"