aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.0.0
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc/gcc-4.0.0')
-rw-r--r--recipes/gcc/gcc-4.0.0/ldflags.patch22
-rw-r--r--recipes/gcc/gcc-4.0.0/zecke-no-host-includes.patch31
-rw-r--r--recipes/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch12
3 files changed, 65 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.0.0/ldflags.patch b/recipes/gcc/gcc-4.0.0/ldflags.patch
new file mode 100644
index 0000000000..1196bf0c8e
--- /dev/null
+++ b/recipes/gcc/gcc-4.0.0/ldflags.patch
@@ -0,0 +1,22 @@
+--- gcc-4.0.0/Makefile.tpl.old 2005-06-10 13:05:09.000000000 +0100
++++ gcc-4.0.0/Makefile.tpl 2005-06-10 13:05:10.000000000 +0100
+@@ -339,7 +339,7 @@
+ NM = @NM@
+
+ LD = @LD@
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+ RANLIB = @RANLIB@
+
+--- gcc-4.0.0/Makefile.in.old 2005-06-10 17:13:12.000000000 +0100
++++ gcc-4.0.0/Makefile.in 2005-06-10 17:13:22.000000000 +0100
+@@ -336,7 +336,7 @@
+ NM = @NM@
+
+ LD = @LD@
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+ RANLIB = @RANLIB@
+
diff --git a/recipes/gcc/gcc-4.0.0/zecke-no-host-includes.patch b/recipes/gcc/gcc-4.0.0/zecke-no-host-includes.patch
new file mode 100644
index 0000000000..6afb10d6ef
--- /dev/null
+++ b/recipes/gcc/gcc-4.0.0/zecke-no-host-includes.patch
@@ -0,0 +1,31 @@
+Index: gcc-4.0.2/gcc/c-incpath.c
+===================================================================
+--- gcc-4.0.2.orig/gcc/c-incpath.c 2005-01-23 16:05:27.000000000 +0100
++++ gcc-4.0.2/gcc/c-incpath.c 2006-05-15 21:23:02.000000000 +0200
+@@ -350,6 +350,26 @@
+ p->construct = 0;
+ p->user_supplied_p = user_supplied_p;
+
++#ifdef CROSS_COMPILE
++ /* A common error when cross compiling is including
++ host headers. This code below will try to fail fast
++ for cross compiling. Currently we consider /usr/include,
++ /opt/include and /sw/include as harmful. */
++ {
++ /* printf("Adding Path: %s\n", p->name ); */
++ if( strstr(p->name, "/usr/include" ) == p->name ) {
++ fprintf(stderr, _("CROSS COMPILE Badness: /usr/include in INCLUDEPATH: %s\n"), p->name);
++ abort();
++ } else if( strstr(p->name, "/sw/include") == p->name ) {
++ fprintf(stderr, _("CROSS COMPILE Badness: /sw/include in INCLUDEPATH: %s\n"), p->name);
++ abort();
++ } else if( strstr(p->name, "/opt/include") == p->name ) {
++ fprintf(stderr, _("CROSS COMPILE Badness: /opt/include in INCLUDEPATH: %s\n"), p->name);
++ abort();
++ }
++ }
++#endif
++
+ add_cpp_dir_path (p, chain);
+ }
+
diff --git a/recipes/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch b/recipes/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..c6ee1577ec
--- /dev/null
+++ b/recipes/gcc/gcc-4.0.0/zecke-xgcc-cpp.patch
@@ -0,0 +1,12 @@
+Index: gcc-4.0.0/Makefile.in
+===================================================================
+--- gcc-4.0.0.orig/Makefile.in 2005-04-21 09:04:10.000000000 +0200
++++ gcc-4.0.0/Makefile.in 2006-08-06 13:14:07.000000000 +0200
+@@ -197,6 +197,7 @@
+ AS="$(AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+ CXXFLAGS="$(CXXFLAGS_FOR_TARGET)"; export CXXFLAGS; \