summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.2.1/Makefile.in.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc/gcc-4.2.1/Makefile.in.patch')
-rw-r--r--recipes/gcc/gcc-4.2.1/Makefile.in.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.2.1/Makefile.in.patch b/recipes/gcc/gcc-4.2.1/Makefile.in.patch
new file mode 100644
index 0000000000..6013f710c0
--- /dev/null
+++ b/recipes/gcc/gcc-4.2.1/Makefile.in.patch
@@ -0,0 +1,38 @@
+Index: gcc-4.2.4/gcc/Makefile.in
+===================================================================
+--- gcc-4.2.4.orig/gcc/Makefile.in
++++ gcc-4.2.4/gcc/Makefile.in
+@@ -570,7 +570,7 @@ LIBGCC2_INCLUDES =
+ TARGET_LIBGCC2_CFLAGS =
+
+ # Options to use when compiling crtbegin/end.
+-CRTSTUFF_CFLAGS = -O2 $(GCC_CFLAGS) $(INCLUDES) $(MULTILIB_CFLAGS) -g0 \
++CRTSTUFF_CFLAGS = -O2 $(GCC_CFLAGS) $(TARGET_INCLUDES) $(MULTILIB_CFLAGS) -g0 \
+ -finhibit-size-directive -fno-inline-functions -fno-exceptions \
+ -fno-zero-initialized-in-bss -fno-toplevel-reorder \
+ $(INHIBIT_LIBC_CFLAGS)
+@@ -874,9 +874,13 @@ BUILD_ERRORS = build/errors.o
+ # -I$(@D) and -I$(srcdir)/$(@D) cause the subdirectory of the file
+ # currently being compiled, in both source trees, to be examined as well.
+ # libintl.h will be found in ../intl if we are using the included libintl.
+-INCLUDES = -I. -I$(@D) -I$(srcdir) -I$(srcdir)/$(@D) \
++#
++# TARGET_INCLUDES is added to avoid that GMPINC (which points to the host
++# include dir) is used for compiling libgcc.a
++TARGET_INCLUDES = -I. -I$(@D) -I$(srcdir) -I$(srcdir)/$(@D) \
+ -I$(srcdir)/../include @INCINTL@ \
+- $(CPPINC) $(GMPINC) $(DECNUMINC)
++ $(CPPINC) $(DECNUMINC)
++INCLUDES = $(TARGET_INCLUDES) $(GMPINC)
+
+ .c.o:
+ $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) $< $(OUTPUT_OPTION)
+@@ -1485,7 +1489,7 @@ libgcc.a: $(LIBGCC_DEPS)
+ $(MAKE) \
+ CFLAGS="$(CFLAGS) $(WARN_CFLAGS)" \
+ CONFIG_H="$(TCONFIG_H)" TM_H="$(TM_H)" \
+- INCLUDES="$(INCLUDES)" \
++ INCLUDES="$(TARGET_INCLUDES)" \
+ MAKEOVERRIDES= \
+ -f libgcc.mk all
+