aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.2.3.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc/gcc-4.2.3.inc')
-rw-r--r--recipes/gcc/gcc-4.2.3.inc103
1 files changed, 53 insertions, 50 deletions
diff --git a/recipes/gcc/gcc-4.2.3.inc b/recipes/gcc/gcc-4.2.3.inc
index 955a894106..e947cba3b7 100644
--- a/recipes/gcc/gcc-4.2.3.inc
+++ b/recipes/gcc/gcc-4.2.3.inc
@@ -2,67 +2,68 @@ require gcc-common.inc
LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+NATIVEDEPS = "mpfr-native gmp-native"
INC_PR = "r17"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
- file://100-uclibc-conf.patch;patch=1 \
- file://103-uclibc-conf-noupstream.patch;patch=1 \
- file://200-uclibc-locale.patch;patch=1 \
- file://203-uclibc-locale-no__x.patch;patch=1 \
- file://204-uclibc-locale-wchar_fix.patch;patch=1 \
- file://205-uclibc-locale-update.patch;patch=1 \
- file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://305-libmudflap-susv3-legacy.patch;patch=1 \
- file://306-libstdc++-namespace.patch;patch=1 \
- file://307-locale_facets.patch;patch=1 \
- file://402-libbackend_dep_gcov-iov.h.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://740-sh-pr24836.patch;patch=1 \
- file://800-arm-bigendian.patch;patch=1 \
- file://801-arm-bigendian-eabi.patch;patch=1 \
- file://904-flatten-switch-stmt-00.patch;patch=1 \
- file://arm-nolibfloat.patch;patch=1 \
- file://arm-softfloat.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://arm-thumb.patch;patch=1 \
- file://arm-thumb-cache.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://unbreak-armv4t.patch;patch=1 \
- file://cache-amnesia.patch;patch=1 \
- file://gfortran.patch;patch=1 \
- file://gcc-4.0.2-e300c2c3.patch;patch=1 \
- file://fortran-static-linking.patch;patch=1 \
- file://intermask-bigendian.patch;patch=1 \
+ file://100-uclibc-conf.patch \
+ file://103-uclibc-conf-noupstream.patch \
+ file://200-uclibc-locale.patch \
+ file://203-uclibc-locale-no__x.patch \
+ file://204-uclibc-locale-wchar_fix.patch \
+ file://205-uclibc-locale-update.patch \
+ file://300-libstdc++-pic.patch \
+ file://301-missing-execinfo_h.patch \
+ file://302-c99-snprintf.patch \
+ file://303-c99-complex-ugly-hack.patch \
+ file://304-index_macro.patch \
+ file://305-libmudflap-susv3-legacy.patch \
+ file://306-libstdc++-namespace.patch \
+ file://307-locale_facets.patch \
+ file://402-libbackend_dep_gcov-iov.h.patch \
+ file://602-sdk-libstdc++-includes.patch \
+ file://740-sh-pr24836.patch \
+ file://800-arm-bigendian.patch \
+ file://801-arm-bigendian-eabi.patch \
+ file://904-flatten-switch-stmt-00.patch \
+ file://arm-nolibfloat.patch \
+ file://arm-softfloat.patch \
+ file://gcc41-configure.in.patch \
+ file://arm-thumb.patch \
+ file://arm-thumb-cache.patch \
+ file://zecke-xgcc-cpp.patch \
+ file://unbreak-armv4t.patch \
+ file://cache-amnesia.patch \
+ file://gfortran.patch \
+ file://gcc-4.0.2-e300c2c3.patch \
+ file://fortran-static-linking.patch \
+ file://intermask-bigendian.patch \
"
SRC_URI_append_ep93xx = " \
- file://arm-crunch-saveregs.patch;patch=1 \
- file://arm-crunch-20000320.patch;patch=1 \
- file://arm-crunch-compare.patch;patch=1 \
- file://arm-crunch-compare-unordered.patch;patch=1 \
- file://arm-crunch-compare-geu.patch;patch=1 \
- file://arm-crunch-eabi-ieee754.patch;patch=1 \
- file://arm-crunch-eabi-ieee754-div.patch;patch=1 \
- file://arm-crunch-64bit-disable0.patch;patch=1 \
- file://arm-crunch-offset.patch;patch=1 \
- file://arm-crunch-fp_consts.patch;patch=1 \
- file://arm-crunch-neg2.patch;patch=1 \
- file://arm-crunch-predicates3.patch;patch=1 \
- file://arm-crunch-cfcvtds-disable.patch;patch=1 \
- file://arm-crunch-floatsi-disable.patch;patch=1 \
- file://arm-crunch-truncsi-disable.patch;patch=1 \
- file://arm-crunch-cfcvt64-disable.patch;patch=1 \
- file://arm-crunch-cirrus-bugfixes.patch;patch=1 \
+ file://arm-crunch-saveregs.patch \
+ file://arm-crunch-20000320.patch \
+ file://arm-crunch-compare.patch \
+ file://arm-crunch-compare-unordered.patch \
+ file://arm-crunch-compare-geu.patch \
+ file://arm-crunch-eabi-ieee754.patch \
+ file://arm-crunch-eabi-ieee754-div.patch \
+ file://arm-crunch-64bit-disable0.patch \
+ file://arm-crunch-offset.patch \
+ file://arm-crunch-fp_consts.patch \
+ file://arm-crunch-neg2.patch \
+ file://arm-crunch-predicates3.patch \
+ file://arm-crunch-cfcvtds-disable.patch \
+ file://arm-crunch-floatsi-disable.patch \
+ file://arm-crunch-truncsi-disable.patch \
+ file://arm-crunch-cfcvt64-disable.patch \
+ file://arm-crunch-cirrus-bugfixes.patch \
"
PACKAGE_ARCH_ep93xx = "${MACHINE_ARCH}"
-SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
+SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch "
# Language Overrides
FORTRAN = ""
@@ -70,6 +71,8 @@ FORTRAN_linux-gnueabi = ",fortran"
JAVA = ""
EXTRA_OECONF_BASE += " --disable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
+EXTRA_OECONF_INITIAL = "--disable-libmudflap --disable-libgomp --disable-libssp"
+EXTRA_OECONF_INTERMEDIATE = "--disable-libmudflap --disable-libgomp --disable-libssp"
ARM_INSTRUCTION_SET = "arm"