summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.4.3/cache-amnesia.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc/gcc-4.4.3/cache-amnesia.patch')
-rw-r--r--recipes/gcc/gcc-4.4.3/cache-amnesia.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.4.3/cache-amnesia.patch b/recipes/gcc/gcc-4.4.3/cache-amnesia.patch
new file mode 100644
index 0000000000..d5281ea575
--- /dev/null
+++ b/recipes/gcc/gcc-4.4.3/cache-amnesia.patch
@@ -0,0 +1,31 @@
+---
+ gcc/configure | 2 +-
+ gcc/configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: gcc-4.4.1/gcc/configure.ac
+===================================================================
+--- gcc-4.4.1.orig/gcc/configure.ac 2009-03-24 10:46:03.000000000 -0700
++++ gcc-4.4.1/gcc/configure.ac 2009-09-04 19:23:39.751461633 -0700
+@@ -1455,7 +1455,7 @@
+ saved_CFLAGS="${CFLAGS}"
+ CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD}" \
+ LDFLAGS="${LDFLAGS_FOR_BUILD}" \
+- ${realsrcdir}/configure \
++ CONFIG_SITE= ${realsrcdir}/configure --cache-file=./other.cache \
+ --enable-languages=${enable_languages-all} \
+ --target=$target_alias --host=$build_alias --build=$build_alias
+ CFLAGS="${saved_CFLAGS}"
+Index: gcc-4.4.1/gcc/configure
+===================================================================
+--- gcc-4.4.1.orig/gcc/configure 2009-03-24 10:46:03.000000000 -0700
++++ gcc-4.4.1/gcc/configure 2009-09-04 19:25:37.831459717 -0700
+@@ -13531,7 +13531,7 @@
+ saved_CFLAGS="${CFLAGS}"
+ CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD}" \
+ LDFLAGS="${LDFLAGS_FOR_BUILD}" \
+- ${realsrcdir}/configure \
++ CONFIG_SITE= ${realsrcdir}/configure --cache-file=./other.cache \
+ --enable-languages=${enable_languages-all} \
+ --target=$target_alias --host=$build_alias --build=$build_alias
+ CFLAGS="${saved_CFLAGS}"