summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-svn/debian/deb-protoize.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc/gcc-svn/debian/deb-protoize.dpatch')
-rw-r--r--recipes/gcc/gcc-svn/debian/deb-protoize.dpatch47
1 files changed, 0 insertions, 47 deletions
diff --git a/recipes/gcc/gcc-svn/debian/deb-protoize.dpatch b/recipes/gcc/gcc-svn/debian/deb-protoize.dpatch
deleted file mode 100644
index f86ee09942..0000000000
--- a/recipes/gcc/gcc-svn/debian/deb-protoize.dpatch
+++ /dev/null
@@ -1,47 +0,0 @@
-#! /bin/sh -e
-
-# DP: build protoize/unprotoize binaries
-
-if [ $# -eq 3 -a "$2" = '-d' ]; then
- pdir="-d $3"
-elif [ $# -ne 1 ]; then
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-fi
-case "$1" in
- -patch) patch $pdir -f --no-backup-if-mismatch -p0 < $0;;
- -unpatch) patch $pdir -f --no-backup-if-mismatch -R -p0 < $0;;
- *)
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-esac
-exit 0
-
---- gcc/Makefile.in.orig 2007-09-06 21:31:39.864036975 +0200
-+++ gcc/Makefile.in 2007-09-06 21:33:57.836118252 +0200
-@@ -137,7 +137,7 @@
-
- # Selection of languages to be made.
- CONFIG_LANGUAGES = @all_selected_languages@
--LANGUAGES = c gcov$(exeext) gcov-dump$(exeext) $(CONFIG_LANGUAGES)
-+LANGUAGES = c proto gcov$(exeext) gcov-dump$(exeext) $(CONFIG_LANGUAGES)
-
- # Various ways of specifying flags for compilations:
- # CFLAGS is for the user to override to, e.g., do a cross build with -O2.
-@@ -3280,14 +3280,14 @@
- protoize.o: protoize.c $(srcdir)/../include/getopt.h $(CONFIG_H) $(SYSTEM_H) \
- coretypes.h $(TM_H) Makefile version.h cppdefault.h intl.h
- (SHLIB_LINK='$(SHLIB_LINK)'; \
-- $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
-+ $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) -Wno-error \
- $(DRIVER_DEFINES) \
- $(srcdir)/protoize.c $(OUTPUT_OPTION))
-
- unprotoize.o: protoize.c $(srcdir)/../include/getopt.h $(CONFIG_H) \
- $(SYSTEM_H) coretypes.h $(TM_H) Makefile version.h cppdefault.h intl.h
- (SHLIB_LINK='$(SHLIB_LINK)'; \
-- $(CC) -c -DUNPROTOIZE $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
-+ $(CC) -c -DUNPROTOIZE $(ALL_CFLAGS) $(ALL_CPPFLAGS) -Wno-error \
- $(DRIVER_DEFINES) \
- $(srcdir)/protoize.c $(OUTPUT_OPTION))
-