summaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-4.5.inc2
-rw-r--r--recipes/gcc/gcc-4.5/gcc-flags-for-build.patch66
2 files changed, 34 insertions, 34 deletions
diff --git a/recipes/gcc/gcc-4.5.inc b/recipes/gcc/gcc-4.5.inc
index ab9f0dca14..cb41e7e97c 100644
--- a/recipes/gcc/gcc-4.5.inc
+++ b/recipes/gcc/gcc-4.5.inc
@@ -10,7 +10,7 @@ NATIVEDEPS = "mpfr-native gmp-native libmpc-native"
INC_PR = "r3"
-SRCREV = "160413"
+SRCREV = "160764"
PV = "4.5"
# BINV should be incremented after updating to a revision
# after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made
diff --git a/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch b/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
index 510c462e6b..51892855af 100644
--- a/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
+++ b/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
@@ -1,7 +1,7 @@
Index: gcc-4.5/Makefile.def
===================================================================
---- gcc-4.5.orig/Makefile.def 2010-06-04 23:21:43.000000000 -0700
-+++ gcc-4.5/Makefile.def 2010-06-07 18:29:45.867493975 -0700
+--- gcc-4.5.orig/Makefile.def
++++ gcc-4.5/Makefile.def
@@ -240,6 +240,7 @@ flags_to_pass = { flag= AWK ; };
flags_to_pass = { flag= BISON ; };
flags_to_pass = { flag= CC_FOR_BUILD ; };
@@ -12,9 +12,9 @@ Index: gcc-4.5/Makefile.def
flags_to_pass = { flag= FLEX ; };
Index: gcc-4.5/gcc/Makefile.in
===================================================================
---- gcc-4.5.orig/gcc/Makefile.in 2010-06-04 23:20:06.000000000 -0700
-+++ gcc-4.5/gcc/Makefile.in 2010-06-07 18:29:45.877491615 -0700
-@@ -762,7 +762,7 @@ BUILD_LINKERFLAGS = $(BUILD_CFLAGS)
+--- gcc-4.5.orig/gcc/Makefile.in
++++ gcc-4.5/gcc/Makefile.in
+@@ -766,7 +766,7 @@ BUILD_LINKERFLAGS = $(BUILD_CFLAGS)
# Native linker and preprocessor flags. For x-fragment overrides.
BUILD_LDFLAGS=@BUILD_LDFLAGS@
@@ -25,8 +25,8 @@ Index: gcc-4.5/gcc/Makefile.in
GCC_INSTALL_NAME := $(shell echo gcc|sed '$(program_transform_name)')
Index: gcc-4.5/gcc/configure.ac
===================================================================
---- gcc-4.5.orig/gcc/configure.ac 2010-06-07 17:45:41.000000000 -0700
-+++ gcc-4.5/gcc/configure.ac 2010-06-07 18:29:45.877491615 -0700
+--- gcc-4.5.orig/gcc/configure.ac
++++ gcc-4.5/gcc/configure.ac
@@ -1798,16 +1798,18 @@ AC_SUBST(inhibit_libc)
# Also, we cannot run fixincludes.
@@ -52,8 +52,8 @@ Index: gcc-4.5/gcc/configure.ac
# Expand extra_headers to include complete path.
Index: gcc-4.5/Makefile.in
===================================================================
---- gcc-4.5.orig/Makefile.in 2010-06-04 23:21:43.000000000 -0700
-+++ gcc-4.5/Makefile.in 2010-06-07 18:29:45.887501058 -0700
+--- gcc-4.5.orig/Makefile.in
++++ gcc-4.5/Makefile.in
@@ -333,6 +333,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
AS_FOR_BUILD = @AS_FOR_BUILD@
CC_FOR_BUILD = @CC_FOR_BUILD@
@@ -72,9 +72,9 @@ Index: gcc-4.5/Makefile.in
"FLEX=$(FLEX)" \
Index: gcc-4.5/gcc/configure
===================================================================
---- gcc-4.5.orig/gcc/configure 2010-06-07 17:45:41.000000000 -0700
-+++ gcc-4.5/gcc/configure 2010-06-07 18:30:48.917502927 -0700
-@@ -705,6 +705,7 @@ SED
+--- gcc-4.5.orig/gcc/configure
++++ gcc-4.5/gcc/configure
+@@ -707,6 +707,7 @@ SED
LIBTOOL
collect2
STMP_FIXINC
@@ -82,7 +82,7 @@ Index: gcc-4.5/gcc/configure
BUILD_LDFLAGS
BUILD_CFLAGS
CC_FOR_BUILD
-@@ -10980,6 +10981,7 @@ fi
+@@ -10982,6 +10983,7 @@ fi
CC_FOR_BUILD='$(CC)'
BUILD_CFLAGS='$(ALL_CFLAGS)'
BUILD_LDFLAGS='$(LDFLAGS)'
@@ -90,7 +90,7 @@ Index: gcc-4.5/gcc/configure
STMP_FIXINC=stmp-fixinc
# And these apply if build != host, or we are generating coverage data
-@@ -10987,6 +10989,7 @@ if test x$build != x$host || test "x$cov
+@@ -10989,6 +10991,7 @@ if test x$build != x$host || test "x$cov
then
BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
@@ -98,28 +98,28 @@ Index: gcc-4.5/gcc/configure
fi
# Expand extra_headers to include complete path.
-@@ -17106,7 +17109,7 @@ else
+@@ -17108,7 +17111,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17109 "configure"
-+#line 17112 "configure"
+-#line 17111 "configure"
++#line 17114 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -17212,7 +17215,7 @@ else
+@@ -17214,7 +17217,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17215 "configure"
-+#line 17218 "configure"
+-#line 17217 "configure"
++#line 17220 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
Index: gcc-4.5/Makefile.tpl
===================================================================
---- gcc-4.5.orig/Makefile.tpl 2010-06-04 23:21:43.000000000 -0700
-+++ gcc-4.5/Makefile.tpl 2010-06-07 18:29:45.897539904 -0700
+--- gcc-4.5.orig/Makefile.tpl
++++ gcc-4.5/Makefile.tpl
@@ -336,6 +336,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
AS_FOR_BUILD = @AS_FOR_BUILD@
CC_FOR_BUILD = @CC_FOR_BUILD@
@@ -130,8 +130,8 @@ Index: gcc-4.5/Makefile.tpl
DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@
Index: gcc-4.5/configure
===================================================================
---- gcc-4.5.orig/configure 2010-06-07 17:45:40.329993062 -0700
-+++ gcc-4.5/configure 2010-06-07 18:29:45.897539904 -0700
+--- gcc-4.5.orig/configure
++++ gcc-4.5/configure
@@ -651,6 +651,7 @@ GCJ_FOR_BUILD
DLLTOOL_FOR_BUILD
CXX_FOR_BUILD
@@ -140,7 +140,7 @@ Index: gcc-4.5/configure
CFLAGS_FOR_BUILD
CC_FOR_BUILD
AS_FOR_BUILD
-@@ -8027,6 +8028,7 @@ esac
+@@ -8036,6 +8037,7 @@ esac
# our build compiler if desired.
if test x"${build}" = x"${host}" ; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
@@ -148,19 +148,19 @@ Index: gcc-4.5/configure
CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
fi
-@@ -8106,6 +8108,7 @@ done
+@@ -8101,6 +8103,7 @@ done
+
- # Generate default definitions for YACC, M4, LEX and other programs that run
- # on the build machine. These are used if the Makefile can't locate these
- # programs in objdir.
+
+
+
Index: gcc-4.5/configure.ac
===================================================================
---- gcc-4.5.orig/configure.ac 2010-06-07 17:45:40.000000000 -0700
-+++ gcc-4.5/configure.ac 2010-06-07 18:29:45.897539904 -0700
-@@ -3081,6 +3081,7 @@ esac
+--- gcc-4.5.orig/configure.ac
++++ gcc-4.5/configure.ac
+@@ -3089,6 +3089,7 @@ esac
# our build compiler if desired.
if test x"${build}" = x"${host}" ; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
@@ -168,7 +168,7 @@ Index: gcc-4.5/configure.ac
CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
fi
-@@ -3147,6 +3148,7 @@ AC_SUBST(AR_FOR_BUILD)
+@@ -3155,6 +3156,7 @@ AC_SUBST(AR_FOR_BUILD)
AC_SUBST(AS_FOR_BUILD)
AC_SUBST(CC_FOR_BUILD)
AC_SUBST(CFLAGS_FOR_BUILD)