summaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-4.5.inc (renamed from recipes/gcc/gcc-4.5.0.inc)20
-rw-r--r--recipes/gcc/gcc-4.5/100-uclibc-conf.patch (renamed from recipes/gcc/gcc-4.5.0/100-uclibc-conf.patch)0
-rw-r--r--recipes/gcc/gcc-4.5/cache-amnesia.patch (renamed from recipes/gcc/gcc-4.5.0/cache-amnesia.patch)0
-rw-r--r--recipes/gcc/gcc-4.5/fortran-cross-compile-hack.patch (renamed from recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch)0
-rw-r--r--recipes/gcc/gcc-4.5/gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch (renamed from recipes/gcc/gcc-4.5.0/gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch)0
-rw-r--r--recipes/gcc/gcc-4.5/gcc-flags-for-build.patch (renamed from recipes/gcc/gcc-4.5.0/gcc-flags-for-build.patch)82
-rw-r--r--recipes/gcc/gcc-4.5/gcc-uclibc-locale-ctype_touplow_t.patch (renamed from recipes/gcc/gcc-4.5.0/gcc-uclibc-locale-ctype_touplow_t.patch)0
-rw-r--r--recipes/gcc/gcc-4.5/zecke-no-host-includes.patch (renamed from recipes/gcc/gcc-4.5.0/zecke-no-host-includes.patch)0
-rw-r--r--recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch (renamed from recipes/gcc/gcc-4.5.0/zecke-xgcc-cpp.patch)0
-rw-r--r--recipes/gcc/gcc-cross-initial_4.5.bb (renamed from recipes/gcc/gcc-cross-initial_4.5.0.bb)0
-rw-r--r--recipes/gcc/gcc-cross-intermediate_4.5.bb (renamed from recipes/gcc/gcc-cross-intermediate_4.5.0.bb)0
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.5.bb (renamed from recipes/gcc/gcc-cross-sdk_4.5.0.bb)0
-rw-r--r--recipes/gcc/gcc-cross_4.5.bb (renamed from recipes/gcc/gcc-cross_4.5.0.bb)0
-rw-r--r--recipes/gcc/gcc_4.5.bb (renamed from recipes/gcc/gcc_4.5.0.bb)2
14 files changed, 56 insertions, 48 deletions
diff --git a/recipes/gcc/gcc-4.5.0.inc b/recipes/gcc/gcc-4.5.inc
index f445a5798c..50e21793ce 100644
--- a/recipes/gcc/gcc-4.5.0.inc
+++ b/recipes/gcc/gcc-4.5.inc
@@ -7,11 +7,16 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp libmpc"
NATIVEDEPS = "mpfr-native gmp-native libmpc-native"
-FILESPATHPKG .= ":gcc-$PV"
INC_PR = "r1"
-SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=gcc450tarbz2 \
+SRCREV = "160043"
+PV = "4.5"
+BINV = "${PV}.1"
+BRANCH = "gcc-4_5-branch"
+PR_append = "+svnr${SRCPV}"
+
+SRC_URI = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH} \
file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \
file://100-uclibc-conf.patch \
file://gcc-uclibc-locale-ctype_touplow_t.patch \
@@ -22,14 +27,18 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=gcc450tarbz2 \
# Language Overrides
FORTRAN = ""
JAVA = ""
+rename_srcdir (){
+ mv ${WORKDIR}/${BRANCH} ${WORKDIR}/gcc-${PV}
+}
+
+do_unpack_append() {
+ bb.build.exec_func('rename_srcdir', d)
+}
EXTRA_OECONF_BASE = " --enable-libssp \
--disable-bootstrap --disable-libgomp \
--disable-libmudflap"
-SRC_URI[gcc450tarbz2.md5sum] = "ff27b7c4a5d5060c8a8543a44abca31f"
-SRC_URI[gcc450tarbz2.sha256sum] = "8293e9efa68a8ec0fdd0dae9c9bd128a8e742566acd9c8fbcfe79d98ed3756c8"
-
EXTRA_OECONF_INITIAL = "--disable-libmudflap --disable-libgomp --disable-libssp --enable-decimal-float=no"
EXTRA_OECONF_INTERMEDIATE = "--disable-libmudflap --disable-libgomp --disable-libssp"
@@ -37,4 +46,3 @@ EXTRA_OECONF_append_linux-uclibc = " --disable-decimal-float "
EXTRA_OECONF_append_linux-uclibceabi = " --disable-decimal-float "
EXTRA_OECONF_append_linux-uclibcspe = " --disable-decimal-float "
EXTRA_OECONF_append_linux-uclibc = " ${@base_contains('TARGET_ARCH', 'powerpc', '--without-long-double-128', '',d)}"
-
diff --git a/recipes/gcc/gcc-4.5.0/100-uclibc-conf.patch b/recipes/gcc/gcc-4.5/100-uclibc-conf.patch
index 0b799607e8..0b799607e8 100644
--- a/recipes/gcc/gcc-4.5.0/100-uclibc-conf.patch
+++ b/recipes/gcc/gcc-4.5/100-uclibc-conf.patch
diff --git a/recipes/gcc/gcc-4.5.0/cache-amnesia.patch b/recipes/gcc/gcc-4.5/cache-amnesia.patch
index b889f9b6ca..b889f9b6ca 100644
--- a/recipes/gcc/gcc-4.5.0/cache-amnesia.patch
+++ b/recipes/gcc/gcc-4.5/cache-amnesia.patch
diff --git a/recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch b/recipes/gcc/gcc-4.5/fortran-cross-compile-hack.patch
index 348c77006f..348c77006f 100644
--- a/recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch
+++ b/recipes/gcc/gcc-4.5/fortran-cross-compile-hack.patch
diff --git a/recipes/gcc/gcc-4.5.0/gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch b/recipes/gcc/gcc-4.5/gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch
index f33e6c1ea6..f33e6c1ea6 100644
--- a/recipes/gcc/gcc-4.5.0/gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch
+++ b/recipes/gcc/gcc-4.5/gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch
diff --git a/recipes/gcc/gcc-4.5.0/gcc-flags-for-build.patch b/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
index 98b3ecf2e1..905152d430 100644
--- a/recipes/gcc/gcc-4.5.0/gcc-flags-for-build.patch
+++ b/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
@@ -1,7 +1,7 @@
-Index: gcc-4.5+svnr155680/Makefile.def
+Index: gcc-4.5/Makefile.def
===================================================================
---- gcc-4.5+svnr155680.orig/Makefile.def 2010-01-13 01:02:22.627540169 -0800
-+++ gcc-4.5+svnr155680/Makefile.def 2010-01-13 01:05:24.260056951 -0800
+--- gcc-4.5.orig/Makefile.def 2010-05-30 20:32:58.000000000 -0700
++++ gcc-4.5/Makefile.def 2010-05-30 22:40:11.810599683 -0700
@@ -240,6 +240,7 @@ flags_to_pass = { flag= AWK ; };
flags_to_pass = { flag= BISON ; };
flags_to_pass = { flag= CC_FOR_BUILD ; };
@@ -10,11 +10,11 @@ Index: gcc-4.5+svnr155680/Makefile.def
flags_to_pass = { flag= CXX_FOR_BUILD ; };
flags_to_pass = { flag= EXPECT ; };
flags_to_pass = { flag= FLEX ; };
-Index: gcc-4.5+svnr155680/gcc/Makefile.in
+Index: gcc-4.5/gcc/Makefile.in
===================================================================
---- gcc-4.5+svnr155680.orig/gcc/Makefile.in 2010-01-13 01:02:22.675542832 -0800
-+++ gcc-4.5+svnr155680/gcc/Makefile.in 2010-01-13 01:05:24.264047000 -0800
-@@ -755,7 +755,7 @@ BUILD_LINKERFLAGS = $(BUILD_CFLAGS)
+--- gcc-4.5.orig/gcc/Makefile.in 2010-05-30 20:30:34.000000000 -0700
++++ gcc-4.5/gcc/Makefile.in 2010-05-30 22:40:11.820599836 -0700
+@@ -762,7 +762,7 @@ BUILD_LINKERFLAGS = $(BUILD_CFLAGS)
# Native linker and preprocessor flags. For x-fragment overrides.
BUILD_LDFLAGS=@BUILD_LDFLAGS@
@@ -23,11 +23,11 @@ Index: gcc-4.5+svnr155680/gcc/Makefile.in
# Actual name to use when installing a native compiler.
GCC_INSTALL_NAME := $(shell echo gcc|sed '$(program_transform_name)')
-Index: gcc-4.5+svnr155680/gcc/configure.ac
+Index: gcc-4.5/gcc/configure.ac
===================================================================
---- gcc-4.5+svnr155680.orig/gcc/configure.ac 2010-01-13 01:02:22.687541624 -0800
-+++ gcc-4.5+svnr155680/gcc/configure.ac 2010-01-13 01:06:55.711583352 -0800
-@@ -1774,16 +1774,18 @@ AC_SUBST(inhibit_libc)
+--- gcc-4.5.orig/gcc/configure.ac 2010-05-30 22:39:14.000000000 -0700
++++ gcc-4.5/gcc/configure.ac 2010-05-30 22:40:11.820599836 -0700
+@@ -1782,16 +1782,18 @@ AC_SUBST(inhibit_libc)
# Also, we cannot run fixincludes.
# These are the normal (build=host) settings:
@@ -50,11 +50,11 @@ Index: gcc-4.5+svnr155680/gcc/configure.ac
fi
# Expand extra_headers to include complete path.
-Index: gcc-4.5+svnr155680/Makefile.in
+Index: gcc-4.5/Makefile.in
===================================================================
---- gcc-4.5+svnr155680.orig/Makefile.in 2010-01-13 01:02:22.639539865 -0800
-+++ gcc-4.5+svnr155680/Makefile.in 2010-01-13 01:05:24.288038715 -0800
-@@ -328,6 +328,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
+--- gcc-4.5.orig/Makefile.in 2010-05-30 20:32:58.000000000 -0700
++++ gcc-4.5/Makefile.in 2010-05-30 22:40:11.830627507 -0700
+@@ -333,6 +333,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
AS_FOR_BUILD = @AS_FOR_BUILD@
CC_FOR_BUILD = @CC_FOR_BUILD@
CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
@@ -62,7 +62,7 @@ Index: gcc-4.5+svnr155680/Makefile.in
CXXFLAGS_FOR_BUILD = @CXXFLAGS_FOR_BUILD@
CXX_FOR_BUILD = @CXX_FOR_BUILD@
DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@
-@@ -657,6 +658,7 @@ BASE_FLAGS_TO_PASS = \
+@@ -662,6 +663,7 @@ BASE_FLAGS_TO_PASS = \
"BISON=$(BISON)" \
"CC_FOR_BUILD=$(CC_FOR_BUILD)" \
"CFLAGS_FOR_BUILD=$(CFLAGS_FOR_BUILD)" \
@@ -70,10 +70,10 @@ Index: gcc-4.5+svnr155680/Makefile.in
"CXX_FOR_BUILD=$(CXX_FOR_BUILD)" \
"EXPECT=$(EXPECT)" \
"FLEX=$(FLEX)" \
-Index: gcc-4.5+svnr155680/gcc/configure
+Index: gcc-4.5/gcc/configure
===================================================================
---- gcc-4.5+svnr155680.orig/gcc/configure 2010-01-13 01:02:22.663539713 -0800
-+++ gcc-4.5+svnr155680/gcc/configure 2010-01-13 01:07:24.315537016 -0800
+--- gcc-4.5.orig/gcc/configure 2010-05-30 22:39:14.000000000 -0700
++++ gcc-4.5/gcc/configure 2010-05-30 22:42:23.488119238 -0700
@@ -705,6 +705,7 @@ SED
LIBTOOL
collect2
@@ -82,7 +82,7 @@ Index: gcc-4.5+svnr155680/gcc/configure
BUILD_LDFLAGS
BUILD_CFLAGS
CC_FOR_BUILD
-@@ -10911,6 +10912,7 @@ fi
+@@ -10927,6 +10928,7 @@ fi
CC_FOR_BUILD='$(CC)'
BUILD_CFLAGS='$(ALL_CFLAGS)'
BUILD_LDFLAGS='$(LDFLAGS)'
@@ -90,7 +90,7 @@ Index: gcc-4.5+svnr155680/gcc/configure
STMP_FIXINC=stmp-fixinc
# And these apply if build != host, or we are generating coverage data
-@@ -10918,6 +10920,7 @@ if test x$build != x$host || test "x$cov
+@@ -10934,6 +10936,7 @@ if test x$build != x$host || test "x$cov
then
BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
@@ -98,29 +98,29 @@ Index: gcc-4.5+svnr155680/gcc/configure
fi
# Expand extra_headers to include complete path.
-@@ -17037,7 +17040,7 @@ else
+@@ -17053,7 +17056,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17040 "configure"
-+#line 17043 "configure"
+-#line 17056 "configure"
++#line 17059 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -17143,7 +17146,7 @@ else
+@@ -17159,7 +17162,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17146 "configure"
-+#line 17149 "configure"
+-#line 17162 "configure"
++#line 17165 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-Index: gcc-4.5+svnr155680/Makefile.tpl
+Index: gcc-4.5/Makefile.tpl
===================================================================
---- gcc-4.5+svnr155680.orig/Makefile.tpl 2010-01-13 01:02:22.603540396 -0800
-+++ gcc-4.5+svnr155680/Makefile.tpl 2010-01-13 01:05:24.332038114 -0800
-@@ -331,6 +331,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
+--- gcc-4.5.orig/Makefile.tpl 2010-05-30 20:32:58.000000000 -0700
++++ gcc-4.5/Makefile.tpl 2010-05-30 22:40:11.840621166 -0700
+@@ -336,6 +336,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
AS_FOR_BUILD = @AS_FOR_BUILD@
CC_FOR_BUILD = @CC_FOR_BUILD@
CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
@@ -128,10 +128,10 @@ Index: gcc-4.5+svnr155680/Makefile.tpl
CXXFLAGS_FOR_BUILD = @CXXFLAGS_FOR_BUILD@
CXX_FOR_BUILD = @CXX_FOR_BUILD@
DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@
-Index: gcc-4.5+svnr155680/configure
+Index: gcc-4.5/configure
===================================================================
---- gcc-4.5+svnr155680.orig/configure 2010-01-13 01:02:22.615539634 -0800
-+++ gcc-4.5+svnr155680/configure 2010-01-13 01:07:18.940037187 -0800
+--- gcc-4.5.orig/configure 2010-05-30 22:39:13.018100422 -0700
++++ gcc-4.5/configure 2010-05-30 22:40:11.840621166 -0700
@@ -651,6 +651,7 @@ GCJ_FOR_BUILD
DLLTOOL_FOR_BUILD
CXX_FOR_BUILD
@@ -140,7 +140,7 @@ Index: gcc-4.5+svnr155680/configure
CFLAGS_FOR_BUILD
CC_FOR_BUILD
AS_FOR_BUILD
-@@ -7862,6 +7863,7 @@ esac
+@@ -7973,6 +7974,7 @@ esac
# our build compiler if desired.
if test x"${build}" = x"${host}" ; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
@@ -148,7 +148,7 @@ Index: gcc-4.5+svnr155680/configure
CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
fi
-@@ -7940,6 +7942,7 @@ done
+@@ -8052,6 +8054,7 @@ done
@@ -156,11 +156,11 @@ Index: gcc-4.5+svnr155680/configure
# Generate default definitions for YACC, M4, LEX and other programs that run
# on the build machine. These are used if the Makefile can't locate these
# programs in objdir.
-Index: gcc-4.5+svnr155680/configure.ac
+Index: gcc-4.5/configure.ac
===================================================================
---- gcc-4.5+svnr155680.orig/configure.ac 2010-01-13 01:02:22.651540130 -0800
-+++ gcc-4.5+svnr155680/configure.ac 2010-01-13 01:05:24.340037763 -0800
-@@ -3022,6 +3022,7 @@ esac
+--- gcc-4.5.orig/configure.ac 2010-05-30 22:39:12.000000000 -0700
++++ gcc-4.5/configure.ac 2010-05-30 22:40:11.840621166 -0700
+@@ -3061,6 +3061,7 @@ esac
# our build compiler if desired.
if test x"${build}" = x"${host}" ; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
@@ -168,7 +168,7 @@ Index: gcc-4.5+svnr155680/configure.ac
CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
fi
-@@ -3087,6 +3088,7 @@ AC_SUBST(AR_FOR_BUILD)
+@@ -3127,6 +3128,7 @@ AC_SUBST(AR_FOR_BUILD)
AC_SUBST(AS_FOR_BUILD)
AC_SUBST(CC_FOR_BUILD)
AC_SUBST(CFLAGS_FOR_BUILD)
diff --git a/recipes/gcc/gcc-4.5.0/gcc-uclibc-locale-ctype_touplow_t.patch b/recipes/gcc/gcc-4.5/gcc-uclibc-locale-ctype_touplow_t.patch
index ffb37d2976..ffb37d2976 100644
--- a/recipes/gcc/gcc-4.5.0/gcc-uclibc-locale-ctype_touplow_t.patch
+++ b/recipes/gcc/gcc-4.5/gcc-uclibc-locale-ctype_touplow_t.patch
diff --git a/recipes/gcc/gcc-4.5.0/zecke-no-host-includes.patch b/recipes/gcc/gcc-4.5/zecke-no-host-includes.patch
index 4ccf35f627..4ccf35f627 100644
--- a/recipes/gcc/gcc-4.5.0/zecke-no-host-includes.patch
+++ b/recipes/gcc/gcc-4.5/zecke-no-host-includes.patch
diff --git a/recipes/gcc/gcc-4.5.0/zecke-xgcc-cpp.patch b/recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch
index a7722cbfc4..a7722cbfc4 100644
--- a/recipes/gcc/gcc-4.5.0/zecke-xgcc-cpp.patch
+++ b/recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch
diff --git a/recipes/gcc/gcc-cross-initial_4.5.0.bb b/recipes/gcc/gcc-cross-initial_4.5.bb
index 1639511362..1639511362 100644
--- a/recipes/gcc/gcc-cross-initial_4.5.0.bb
+++ b/recipes/gcc/gcc-cross-initial_4.5.bb
diff --git a/recipes/gcc/gcc-cross-intermediate_4.5.0.bb b/recipes/gcc/gcc-cross-intermediate_4.5.bb
index eb59de9461..eb59de9461 100644
--- a/recipes/gcc/gcc-cross-intermediate_4.5.0.bb
+++ b/recipes/gcc/gcc-cross-intermediate_4.5.bb
diff --git a/recipes/gcc/gcc-cross-sdk_4.5.0.bb b/recipes/gcc/gcc-cross-sdk_4.5.bb
index a316cd282e..a316cd282e 100644
--- a/recipes/gcc/gcc-cross-sdk_4.5.0.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.5.bb
diff --git a/recipes/gcc/gcc-cross_4.5.0.bb b/recipes/gcc/gcc-cross_4.5.bb
index 825a7bde8a..825a7bde8a 100644
--- a/recipes/gcc/gcc-cross_4.5.0.bb
+++ b/recipes/gcc/gcc-cross_4.5.bb
diff --git a/recipes/gcc/gcc_4.5.0.bb b/recipes/gcc/gcc_4.5.bb
index 40e1f7c3e5..2ef7229271 100644
--- a/recipes/gcc/gcc_4.5.0.bb
+++ b/recipes/gcc/gcc_4.5.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "${INC_PR}.0"
require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc