aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gd/gd_2.0.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gd/gd_2.0.21.bb')
-rw-r--r--recipes/gd/gd_2.0.21.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/gd/gd_2.0.21.bb b/recipes/gd/gd_2.0.21.bb
new file mode 100644
index 0000000000..03a506b882
--- /dev/null
+++ b/recipes/gd/gd_2.0.21.bb
@@ -0,0 +1,24 @@
+SECTION = "libs"
+LICENSE = "GD"
+DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
+DEPENDS = "libpng jpeg zlib"
+
+SRC_URI = "http://www.boutell.com/gd/http/gd-${PV}.tar.gz"
+S = "${WORKDIR}/gd-${PV}"
+
+inherit autotools gettext
+
+EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
+ --with-png=${STAGING_LIBDIR}/.. \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --without-xpm"
+
+headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
+ gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
+
+do_stage () {
+ oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
+ for i in ${headers}; do
+ install -m 0644 $i ${STAGING_INCDIR}/
+ done
+}