aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdal/gdal_1.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gdal/gdal_1.5.2.bb')
-rw-r--r--recipes/gdal/gdal_1.5.2.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/gdal/gdal_1.5.2.bb b/recipes/gdal/gdal_1.5.2.bb
new file mode 100644
index 0000000000..a92e40fadc
--- /dev/null
+++ b/recipes/gdal/gdal_1.5.2.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE = "http://www.gdal.org/"
+LICENSE = "MIT"
+DEPENDS = "proj-4 sqlite3 zlib jpeg libpng tiff giflib curl jasper expat"
+PR = "r2"
+
+SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz \
+ file://gdal_config.patch;patch=1 \
+ "
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--without-perl \
+ --without-python \
+ --without-php \
+ --without-ruby \
+ --with-libz=${STAGING_DIR_TARGET} \
+ --with-png=${STAGING_DIR_TARGET} \
+ --with-jpeg=${STAGING_DIR_TARGET} \
+ --with-libtiff=${STAGING_DIR_TARGET} \
+ --with-gif=${STAGING_DIR_TARGET} \
+ --with-jasper=${STAGING_DIR_TARGET} \
+ --with-expat=${STAGING_DIR_TARGET} \
+ --with-expat-inc=${STAGING_INCDIR} \
+ --with-expat-lib=${STAGING_LIBDIR} \
+"
+
+# GDAL clutter /usr/share with files instead of using a subdir :(
+FILES_${PN}-dev += "${datadir}"
+
+do_compile() {
+ oe_runmake default
+}
+
+do_stage() {
+ autotools_stage_all
+}
+