aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/geda/geda-xgsch2pcb_0.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/geda/geda-xgsch2pcb_0.1.2.bb')
-rw-r--r--recipes/geda/geda-xgsch2pcb_0.1.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/geda/geda-xgsch2pcb_0.1.2.bb b/recipes/geda/geda-xgsch2pcb_0.1.2.bb
new file mode 100644
index 0000000000..ccfe151955
--- /dev/null
+++ b/recipes/geda/geda-xgsch2pcb_0.1.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Graphical front-end for the gschem -> pcb workflow"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/icons"
+
+DEPENDS = "python-native"
+# python-codecs for gettext.py
+RDEPENDS = "geda-gschem geda-utils pcb python-codecs python-dbus python-pygtk python-subprocess"
+
+SRC_URI = "http://geda.seul.org/dist/${P}.tar.gz \
+ file://skip-python-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-update-desktop-database"
+
+do_configure_prepend() {
+ sed -i -e s:\\\$\(PYTHON\):${bindir}/python:g Makefile.am
+}