aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/genlist/genlist.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/genlist/genlist.bb')
-rw-r--r--recipes/genlist/genlist.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/genlist/genlist.bb b/recipes/genlist/genlist.bb
new file mode 100644
index 0000000000..6c8695228b
--- /dev/null
+++ b/recipes/genlist/genlist.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "IP Address List Generator"
+SECTION = "utils"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "file://genlist.c \
+ file://Makefile"
+
+DEFAULT_PREFERENCE="-1"
+
+S = "${WORKDIR}"
+
+do_compile() {
+ oe_runmake all
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 genlist ${D}${bindir}/
+}