aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/geode-drivers
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/geode-drivers')
-rw-r--r--recipes/geode-drivers/geode-accessbus5536_2.6.11.bb12
-rw-r--r--recipes/geode-drivers/geode-aeslx_2.6.11.bb19
-rw-r--r--recipes/geode-drivers/geode-alsa5536_2.6.11.bb12
-rw-r--r--recipes/geode-drivers/geode-modules.inc26
4 files changed, 69 insertions, 0 deletions
diff --git a/recipes/geode-drivers/geode-accessbus5536_2.6.11.bb b/recipes/geode-drivers/geode-accessbus5536_2.6.11.bb
new file mode 100644
index 0000000000..a8bf901b6f
--- /dev/null
+++ b/recipes/geode-drivers/geode-accessbus5536_2.6.11.bb
@@ -0,0 +1,12 @@
+# AccessBus OE build file for the AMD Geode 5535/5536
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Linux Access Bus driver for the AMD Geode 5535/5536"
+HOMEPAGE = "http://www.amd.com/embedded"
+
+PR = "r0"
+AMD_DRIVER_VERSION = "01.00.0401"
+AMD_DRIVER_LABEL = "AccessBus_Linux_5536_${AMD_DRIVER_VERSION}"
+
+require geode-modules.inc \ No newline at end of file
diff --git a/recipes/geode-drivers/geode-aeslx_2.6.11.bb b/recipes/geode-drivers/geode-aeslx_2.6.11.bb
new file mode 100644
index 0000000000..fdcbdbf20b
--- /dev/null
+++ b/recipes/geode-drivers/geode-aeslx_2.6.11.bb
@@ -0,0 +1,19 @@
+# AES OE build file for the AMD Geode LX
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Linux AES Driver for the AMD Geode LX processor"
+HOMEPAGE = "http://www.amd.com/embedded"
+
+PR = "r0"
+AMD_DRIVER_VERSION = "02.01.0100"
+AMD_DRIVER_LABEL = "AES_Linux_LX_${AMD_DRIVER_VERSION}"
+
+require geode-modules.inc
+
+FILES_${PN} += " /etc"
+
+do_install_append(){
+ install -d ${D}/etc/modules.d
+ echo options geodeaes rsvd_mem=0x200000 > ${D}/etc/modules.d/aes
+}
diff --git a/recipes/geode-drivers/geode-alsa5536_2.6.11.bb b/recipes/geode-drivers/geode-alsa5536_2.6.11.bb
new file mode 100644
index 0000000000..ff2fcd8df0
--- /dev/null
+++ b/recipes/geode-drivers/geode-alsa5536_2.6.11.bb
@@ -0,0 +1,12 @@
+# ALSA OE build file for the AMD Geode 5535/5536
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Linux 2.6.11 ALSA Audio Driver for the AMD Geode 5535/5536 companion chip"
+HOMEPAGE = "http://www.amd.com/embedded"
+
+PR = "r0"
+AMD_DRIVER_VERSION = "1.00.0500"
+AMD_DRIVER_LABEL = "Audio_LinuxALSA_5536_${AMD_DRIVER_VERSION}"
+
+require geode-modules.inc \ No newline at end of file
diff --git a/recipes/geode-drivers/geode-modules.inc b/recipes/geode-drivers/geode-modules.inc
new file mode 100644
index 0000000000..d6102baf8d
--- /dev/null
+++ b/recipes/geode-drivers/geode-modules.inc
@@ -0,0 +1,26 @@
+# FIXME, consider using kernel staging directory instead of KERNEL_SOURCE which is
+# located in the work directory. see module.bbclass
+
+# Linux kernel modules OE build files for the AMD Geode GX5535/LX5536
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+LICENSE = "GPL"
+HOMEPAGE = "http://www.amd.com/embedded"
+
+inherit autotools module-base
+
+export ARCH="i386"
+
+DEPENDS += " virtual/kernel"
+
+S="${WORKDIR}/${AMD_DRIVER_LABEL}"
+
+PACKAGES="${PN}"
+FILES_${PN} = "/lib"
+
+KERNEL_SOURCE = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')}"
+
+EXTRA_OECONF="--with-kernel-path=${KERNEL_SOURCE} --with-module-path=${D}/lib/modules"
+
+SRC_URI = "http://www.amd.com/files/connectivitysolutions/geode/geode_lx/${AMD_DRIVER_LABEL}.tar.gz"