summaryrefslogtreecommitdiffstats
path: root/recipes/gloox
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gloox')
-rw-r--r--recipes/gloox/gloox/gloox-fix-pc.diff10
-rw-r--r--recipes/gloox/gloox_0.8.1.bb15
-rw-r--r--recipes/gloox/gloox_0.8.9.bb16
3 files changed, 41 insertions, 0 deletions
diff --git a/recipes/gloox/gloox/gloox-fix-pc.diff b/recipes/gloox/gloox/gloox-fix-pc.diff
new file mode 100644
index 0000000000..70cb84eb09
--- /dev/null
+++ b/recipes/gloox/gloox/gloox-fix-pc.diff
@@ -0,0 +1,10 @@
+Index: gloox-0.8.9/gloox.pc.in
+===================================================================
+--- gloox-0.8.9.orig/gloox.pc.in 2008-11-04 04:20:26.896779618 +0300
++++ gloox-0.8.9/gloox.pc.in 2008-11-04 04:20:32.665427239 +0300
+@@ -7,4 +7,4 @@ Name: gloox
+ Description: A high-level XMPP/Jabber library for C++
+ Version: @VERSION@
+ Libs: -L${libdir} -lgloox @LIBS@
+-Cflags: -I${includedir} @CFLAGS@
++Cflags: -I${includedir}
diff --git a/recipes/gloox/gloox_0.8.1.bb b/recipes/gloox/gloox_0.8.1.bb
new file mode 100644
index 0000000000..09004a8182
--- /dev/null
+++ b/recipes/gloox/gloox_0.8.1.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPL"
+DESCRIPTION = "full-featured Jabber/XMPP client library."
+SECTION = "networking"
+PRIORITY = "optional"
+PR = "r0"
+
+DEPENDS = "iksemel libidn gnutls"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://camaya.net/download/${P}.tar.bz2"
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/gloox/gloox_0.8.9.bb b/recipes/gloox/gloox_0.8.9.bb
new file mode 100644
index 0000000000..562fb90eb3
--- /dev/null
+++ b/recipes/gloox/gloox_0.8.9.bb
@@ -0,0 +1,16 @@
+LICENSE = "GPL"
+DESCRIPTION = "full-featured Jabber/XMPP client library."
+SECTION = "networking"
+PRIORITY = "optional"
+PR = "r0"
+
+DEPENDS = "iksemel libidn gnutls"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://camaya.net/download/${P}.tar.bz2 \
+ file://gloox-fix-pc.diff;patch=1"
+
+do_stage () {
+ autotools_stage_all
+}