summaryrefslogtreecommitdiffstats
path: root/recipes/gnet/gnet_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnet/gnet_cvs.bb')
-rw-r--r--recipes/gnet/gnet_cvs.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/gnet/gnet_cvs.bb b/recipes/gnet/gnet_cvs.bb
new file mode 100644
index 0000000000..b36df17c18
--- /dev/null
+++ b/recipes/gnet/gnet_cvs.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "GNet is a simple network library. It is written in C, object-oriented, and built upon GLib."
+LICENSE = "LGPL"
+SECTION = "libs/network"
+HOMEPAGE = "http://www.gnetlibrary.org"
+DEPENDS = "glib-2.0"
+PV = "2.0.7+cvs${SRCDATE}"
+
+SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gnet \
+ file://buildfix.patch;patch=1"
+S = "${WORKDIR}/gnet"
+
+EXTRA_OECONF = "--disable-pthreads"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}