summaryrefslogtreecommitdiffstats
path: root/recipes/gnet/gnet_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnet/gnet_svn.bb')
-rw-r--r--recipes/gnet/gnet_svn.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/gnet/gnet_svn.bb b/recipes/gnet/gnet_svn.bb
new file mode 100644
index 0000000000..c09b7f8b9c
--- /dev/null
+++ b/recipes/gnet/gnet_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GNet is a simple network library. It is written in C, object-oriented, and built upon GLib."
+LICENSE = "LGPL"
+SECTION = "libs/network"
+HOMEPAGE = "http://www.gnetlibrary.org"
+DEPENDS = "glib-2.0"
+PV = "2.0.7+svn${SRCDATE}"
+
+SRC_URI = "svn://svn.gnome.org/svn/${PN}/;module=trunk \
+ file://buildfix.patch;patch=1"
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--disable-pthreads"
+
+FILES_${PN}-dev += "${libdir}/gnet-2.0"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}