aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-common_2.18.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-common_2.18.0.bb')
-rw-r--r--recipes/gnome/gnome-common_2.18.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-common_2.18.0.bb b/recipes/gnome/gnome-common_2.18.0.bb
new file mode 100644
index 0000000000..41c25b69c2
--- /dev/null
+++ b/recipes/gnome/gnome-common_2.18.0.bb
@@ -0,0 +1,28 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+PR = "r0"
+DESCRIPTION = "Common macros for building GNOME applications"
+inherit gnome
+
+# The omf.make file failed if scrollkeeper doesn't happen to be
+# installed
+
+SRC_URI += "file://omf.patch;patch=1"
+
+EXTRA_AUTORECONF = ""
+DEPENDS = ""
+
+FILES_${PN} += "${datadir}/aclocal"
+FILES_${PN}-dev = ""
+
+do_stage () {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ make DESTDIR="${STAGE_TEMP}" install
+ cp -pPR ${STAGE_TEMP}${bindir}/* ${STAGING_BINDIR_NATIVE}
+ install -d ${STAGING_DATADIR}/gnome-common
+ install -d ${STAGING_DATADIR}/aclocal
+ cp -pPR ${STAGE_TEMP}${datadir}/gnome-common/* ${STAGING_DATADIR}/gnome-common
+ cp -pPR ${STAGE_TEMP}${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
+ rm -rf ${STAGE_TEMP}
+}