aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-keyring_2.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-keyring_2.20.0.bb')
-rw-r--r--recipes/gnome/gnome-keyring_2.20.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-keyring_2.20.0.bb b/recipes/gnome/gnome-keyring_2.20.0.bb
new file mode 100644
index 0000000000..2f72c5dfb1
--- /dev/null
+++ b/recipes/gnome/gnome-keyring_2.20.0.bb
@@ -0,0 +1,23 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+
+PR = "r2"
+
+inherit autotools gnome pkgconfig
+
+DEPENDS = "gtk+ libgcrypt"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+SRC_URI += "file://org.gnome.keyring.service"
+
+do_install_append () {
+ install -d ${D}${datadir}/dbus-1/services
+ install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services"
+
+do_stage() {
+ autotools_stage_all
+}