aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-panel_2.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-panel_2.24.0.bb')
-rw-r--r--recipes/gnome/gnome-panel_2.24.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-panel_2.24.0.bb b/recipes/gnome/gnome-panel_2.24.0.bb
new file mode 100644
index 0000000000..743e0fafd7
--- /dev/null
+++ b/recipes/gnome/gnome-panel_2.24.0.bb
@@ -0,0 +1,24 @@
+LICENSE = "GPL"
+DEPENDS = "librsvg libgweather startup-notification libwnck orbit2 gtk+ libgnome libgnomeui gnome-desktop libglade gnome-menus orbit2-native"
+
+inherit gnome pkgconfig
+
+SRC_URI += "file://scrollkeeper.patch;patch=1"
+
+do_configure_prepend() {
+ sed -i -e s:help:: ${S}/Makefile.am
+}
+
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+ ${datadir}/icons"
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+EXTRA_OECONF = "--disable-scrollkeeper"
+
+do_stage() {
+ autotools_stage_all
+}