aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-python-desktop_2.23.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-python-desktop_2.23.0.bb')
-rw-r--r--recipes/gnome/gnome-python-desktop_2.23.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-python-desktop_2.23.0.bb b/recipes/gnome/gnome-python-desktop_2.23.0.bb
new file mode 100644
index 0000000000..0ddc05e8e0
--- /dev/null
+++ b/recipes/gnome/gnome-python-desktop_2.23.0.bb
@@ -0,0 +1,28 @@
+LICENSE = "GPL/LGPL"
+DEPENDS = "librsvg libwnck totem-pl-parser libgtop gnome-panel gnome-desktop eds-dbus python-pygtk gnome-python libgnomeprint libgnomeprintui"
+
+PR = "r4"
+
+inherit gnome distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+do_configure_prepend() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=defsdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=argtypesdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/argtypes\":g \
+ ${S}/configure.ac
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dev += "${datadir}/pygtk"