aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/gnome-python_2.26.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/gnome-python_2.26.1.bb')
-rw-r--r--recipes/gnome/gnome-python_2.26.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gnome/gnome-python_2.26.1.bb b/recipes/gnome/gnome-python_2.26.1.bb
new file mode 100644
index 0000000000..1027437b7a
--- /dev/null
+++ b/recipes/gnome/gnome-python_2.26.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GNOME Python miscellaneous bindings"
+LICENSE = "LGPL"
+DEPENDS = "libgnomeui pyorbit python-pygtk"
+RDEPENDS = "pyorbit"
+
+inherit gnome distutils-base pkgconfig
+
+do_configure() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.ac
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ autotools_do_configure
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}"
+FILES_${PN}-dbg += "${libdir}/gnome-vfs-2.0/modules/.debug"
+
+