aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/libgweather_2.26.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/libgweather_2.26.2.1.bb')
-rw-r--r--recipes/gnome/libgweather_2.26.2.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gnome/libgweather_2.26.2.1.bb b/recipes/gnome/libgweather_2.26.2.1.bb
new file mode 100644
index 0000000000..e97bff1aee
--- /dev/null
+++ b/recipes/gnome/libgweather_2.26.2.1.bb
@@ -0,0 +1,28 @@
+LICENSE = "LGPL"
+DEPENDS = "libgnome libsoup-2.4 gtk+"
+
+PR = "r1"
+
+inherit gnome
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_prepend() {
+ sed -i -e 's:help::' ${S}/Makefile.am
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gnome* \
+ ${datadir}/icons"
+
+PACKAGES =+ "${PN}-locationdata"
+FILES_${PN}-locationdata = "${datadir}/libgweather/Locations*"
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+