aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/libsoup_2.2.100.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/libsoup_2.2.100.bb')
-rw-r--r--recipes/gnome/libsoup_2.2.100.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/gnome/libsoup_2.2.100.bb b/recipes/gnome/libsoup_2.2.100.bb
new file mode 100644
index 0000000000..d69a985627
--- /dev/null
+++ b/recipes/gnome/libsoup_2.2.100.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "An HTTP library implementation in C"
+LICENSE = "GPL"
+SECTION = "x11/gnome/libs"
+
+PR = "r1"
+
+DEPENDS = "glib-2.0 gnutls libxml2"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${PN}/2.2/${PN}-${PV}.tar.bz2"
+
+inherit autotools
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev = "${includedir}/ ${libdir}/"
+FILES_${PN}-doc = "${datadir}/"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}