aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome/pyorbit_2.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome/pyorbit_2.24.0.bb')
-rw-r--r--recipes/gnome/pyorbit_2.24.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/gnome/pyorbit_2.24.0.bb b/recipes/gnome/pyorbit_2.24.0.bb
new file mode 100644
index 0000000000..c98b99d1d5
--- /dev/null
+++ b/recipes/gnome/pyorbit_2.24.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Python Orbit bindings"
+LICENSE = "LGPL"
+
+PR = "r1"
+
+inherit gnome distutils-base pkgconfig
+
+SRC_URI += "file://acinclude.m4"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+EXTRA_OEMAKE = "-e"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ export CC=${TARGET_PREFIX}gcc
+ autotools_do_configure
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/pyorbit-2
+ install -m 0644 src/pyorbit.h ${STAGING_INCDIR}/pyorbit-2
+ autotools_stage_all
+}