aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnome
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnome')
-rw-r--r--recipes/gnome/dconf_0.5.1.bb15
-rwxr-xr-xrecipes/gnome/gdm-2.30.0/Default96
-rw-r--r--recipes/gnome/gdm_2.30.0.bb6
-rw-r--r--recipes/gnome/gedit-plugins_2.30.0.bb19
-rw-r--r--recipes/gnome/gnome-backgrounds_2.32.0.bb11
-rw-r--r--recipes/gnome/gnome-bluetooth_2.30.0.bb2
-rw-r--r--recipes/gnome/gnome-bluetooth_2.32.0.bb29
-rw-r--r--recipes/gnome/gnome-control-center_2.32.1.bb28
-rw-r--r--recipes/gnome/gnome-desktop.inc5
-rw-r--r--recipes/gnome/gnome-desktop_2.32.1.bb17
-rw-r--r--recipes/gnome/gnome-doc-utils.inc6
-rw-r--r--recipes/gnome/gnome-keyring_2.32.1.bb31
-rw-r--r--recipes/gnome/gnome-media_2.32.0.bb25
-rw-r--r--recipes/gnome/gnome-menus_2.30.5.bb17
-rw-r--r--recipes/gnome/gnome-nettool_2.32.0.bb10
-rw-r--r--recipes/gnome/gnome-python-desktop_2.32.0.bb31
-rw-r--r--recipes/gnome/gnome-session_2.30.2.bb22
-rw-r--r--recipes/gnome/gnome-system-tools_2.32.0.bb17
-rw-r--r--recipes/gnome/gnome-themes_2.32.1.bb26
-rw-r--r--recipes/gnome/gnome-utils_2.32.0.bb29
-rw-r--r--recipes/gnome/gsettings-desktop-schemas_3.0.0.bb15
-rw-r--r--recipes/gnome/libgnome-keyring_2.32.0.bb10
-rw-r--r--recipes/gnome/libgnome_2.32.1.bb24
-rw-r--r--recipes/gnome/libgnomekbd_2.32.0.bb20
-rw-r--r--recipes/gnome/liboobs_2.32.0.bb9
-rw-r--r--recipes/gnome/libwnck/introspection.patch13
-rw-r--r--recipes/gnome/libwnck_2.30.5.bb11
-rw-r--r--recipes/gnome/system-tools-backends_2.10.1.bb2
-rw-r--r--recipes/gnome/zenity_2.28.0.bb2
29 files changed, 521 insertions, 27 deletions
diff --git a/recipes/gnome/dconf_0.5.1.bb b/recipes/gnome/dconf_0.5.1.bb
new file mode 100644
index 0000000000..07e391558b
--- /dev/null
+++ b/recipes/gnome/dconf_0.5.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Gnome dconf"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = ""
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "c905497d0255fe2ba58564f9655908ab"
+SRC_URI[archive.sha256sum] = "0083d70e1b5e540d8d4b3f04fa5d17dff4c574136682fe3bdd9b5ecc196ec4f6"
+
+FILES_${PN} += "${datadir}/dbus-1/ \
+ ${datadir}/vala \
+ ${libdir}//gio/modules/*.so \
+ "
+
diff --git a/recipes/gnome/gdm-2.30.0/Default b/recipes/gnome/gdm-2.30.0/Default
new file mode 100755
index 0000000000..a7a7fcf7fd
--- /dev/null
+++ b/recipes/gnome/gdm-2.30.0/Default
@@ -0,0 +1,96 @@
+#!/bin/sh
+# Stolen from the debian kdm setup, aren't I sneaky
+# Plus a lot of fun stuff added
+# -George
+
+PATH="/usr/bin:$PATH"
+OLD_IFS=$IFS
+
+gdmwhich () {
+ COMMAND="$1"
+ OUTPUT=
+ IFS=:
+ for dir in $PATH
+ do
+ if test -x "$dir/$COMMAND" ; then
+ if test "x$OUTPUT" = "x" ; then
+ OUTPUT="$dir/$COMMAND"
+ fi
+ fi
+ done
+ IFS=$OLD_IFS
+ echo "$OUTPUT"
+}
+
+sysresources=/etc/X11/Xresources
+
+# merge in defaults
+if [ -f "$sysresources" ]; then
+ xrdb -merge "$sysresources"
+fi
+
+sysmodmap=/etc/X11/Xmodmap
+
+XMODMAP=`gdmwhich xmodmap`
+if [ "x$XMODMAP" != "x" ] ; then
+ if [ "x$GDM_PARENT_DISPLAY" = "x" ]; then
+ if [ -f $sysmodmap ]; then
+ $XMODMAP $sysmodmap
+ fi
+ else
+ ( DISPLAY=$GDM_PARENT_DISPLAY XAUTHORITY=$GDM_PARENT_XAUTHORITY $XMODMAP -pke ) | $XMODMAP -
+ fi
+
+ #
+ # Switch Sun's Alt and Meta mod mappings
+ #
+
+ UNAME=`gdmwhich uname`
+ PROCESSOR=`$UNAME -p`
+ if [ "x$PROCESSOR" = "xsparc" ]; then
+ if $XMODMAP | /usr/bin/grep mod4 | /usr/bin/grep Alt > /dev/null 2>/dev/null
+ then
+ $XMODMAP -e "clear Mod1" \
+ -e "clear Mod4" \
+ -e "add Mod1 = Alt_L" \
+ -e "add Mod1 = Alt_R" \
+ -e "add Mod4 = Meta_L" \
+ -e "add Mod4 = Meta_R"
+ fi
+ fi
+fi
+
+SETXKBMAP=`gdmwhich setxkbmap`
+if [ "x$SETXKBMAP" != "x" ] ; then
+ # FIXME: is this all right? Is this completely on crack?
+ # What this does is move the xkb configuration from the GDM_PARENT_DISPLAY
+ # FIXME: This should be done in code. Or there must be an easier way ...
+ if [ -n "$GDM_PARENT_DISPLAY" ]; then
+ XKBSETUP=`( DISPLAY=$GDM_PARENT_DISPLAY XAUTHORITY=$GDM_PARENT_XAUTHORITY $SETXKBMAP -v )`
+ if [ -n "$XKBSETUP" ]; then
+ XKBKEYMAP=`echo "$XKBSETUP" | grep '^keymap' | awk '{ print $2 }'`
+ XKBTYPES=`echo "$XKBSETUP" | grep '^types' | awk '{ print $2 }'`
+ XKBCOMPAT=`echo "$XKBSETUP" | grep '^compat' | awk '{ print $2 }'`
+ XKBSYMBOLS=`echo "$XKBSETUP" | grep '^symbols' | awk '{ print $2 }'`
+ XKBGEOMETRY=`echo "$XKBSETUP" | grep '^geometry' | awk '{ print $2 }'`
+ if [ -n "$XKBKEYMAP" ]; then
+ $SETXKBMAP -keymap "$XKBKEYMAP"
+ elif [ -n "$XKBTYPES" -a -n "$XKBCOMPAT" -a -n "$XKBSYMBOLS" -a -n "$XKBGEOMETRY" ]; then
+ $SETXKBMAP -types "$XKBTYPES" -compat "$XKBCOMPAT" -symbols "$XKBSYMBOLS" -geometry "$XKBGEOMETRY"
+ elif [ -n "$XKBTYPES" -a -n "$XKBCOMPAT" -a -n "$XKBSYMBOLS" ]; then
+ $SETXKBMAP -types "$XKBTYPES" -compat "$XKBCOMPAT" -symbols "$XKBSYMBOLS"
+ elif [ -n "$XKBSYMBOLS" ]; then
+ $SETXKBMAP -symbols "$XKBSYMBOLS"
+ fi
+ fi
+ fi
+fi
+
+# FIXME: the housekeeping below really should be moved to the postinst of packages that require it
+# brute force approach for now
+update-desktop-database
+glib-compile-schemas /usr/share/glib-2.0/schemas/
+
+#x11vnc -q -bg -display :0 -forever -avahi -xkb
+
+exit 0
diff --git a/recipes/gnome/gdm_2.30.0.bb b/recipes/gnome/gdm_2.30.0.bb
index 7352bf3e1f..b12dbf8f67 100644
--- a/recipes/gnome/gdm_2.30.0.bb
+++ b/recipes/gnome/gdm_2.30.0.bb
@@ -5,6 +5,8 @@ DEPENDS = "xinput gnome-panel tcp-wrappers libcanberra libxklavier grep consolek
inherit gnome update-rc.d
+PR = "r1"
+
RDEPENDS_${PN} += "grep dbus-x11 shadow libpam-base-files"
SRC_URI += " \
@@ -13,6 +15,7 @@ SRC_URI += " \
file://gdm \
file://gdm.conf \
file://gdm-pam \
+ file://Default \
"
SRC_URI[archive.md5sum] = "0da84637abbcbf1666529d6192a81e6b"
@@ -37,6 +40,9 @@ do_install_append() {
install -d ${D}/${sysconfdir}/pam.d
install -m 0755 ${WORKDIR}/gdm-pam ${D}/${sysconfdir}/pam.d/gdm
+
+ install -d ${D}/${sysconfdir}/gdm/Init
+ install -m 0755 ${WORKDIR}/Default ${D}/${sysconfdir}/gdm/Init
}
FILES_${PN} += "${datadir}/icon* \
diff --git a/recipes/gnome/gedit-plugins_2.30.0.bb b/recipes/gnome/gedit-plugins_2.30.0.bb
new file mode 100644
index 0000000000..f3c55f62e2
--- /dev/null
+++ b/recipes/gnome/gedit-plugins_2.30.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "GNOME editor plugins"
+SECTION = "x11/gnome"
+LICENSE = "GPL"
+
+DEPENDS = "gedit"
+
+inherit gnome
+SRC_URI[archive.md5sum] = "f1200605247b3ece1212c363f0b04c1d"
+SRC_URI[archive.sha256sum] = "8a177f2455ee5c58bc4a19df013d5698b14ae6a3f31ed48347904cf467a79509"
+
+FILES_${PN} += " \
+ ${libdir}/gedit-2/plugins \
+ ${datadir}/gedit-2/plugins \
+ "
+
+FILES_${PN}-dbg += " \
+ ${libdir}/gedit-2/plugins/.debug \
+ "
+
diff --git a/recipes/gnome/gnome-backgrounds_2.32.0.bb b/recipes/gnome/gnome-backgrounds_2.32.0.bb
new file mode 100644
index 0000000000..e4ce8d257d
--- /dev/null
+++ b/recipes/gnome/gnome-backgrounds_2.32.0.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Gnome background images"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "3df26626483b02e51adefc6ab5945a8d"
+SRC_URI[archive.sha256sum] = "4d7b60b5ba768bf8834b5fa3a3471cd9a9e14b5884bc210dc2d3cdbf1faddcef"
+
+FILES_${PN} += "${datadir}/gnome-background-properties"
+
diff --git a/recipes/gnome/gnome-bluetooth_2.30.0.bb b/recipes/gnome/gnome-bluetooth_2.30.0.bb
index 535735a3a6..238d039fb3 100644
--- a/recipes/gnome/gnome-bluetooth_2.30.0.bb
+++ b/recipes/gnome/gnome-bluetooth_2.30.0.bb
@@ -19,7 +19,7 @@ do_configure_prepend() {
}
do_configure_append() {
- sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${TARGET_PREFIX}libtool
+ sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${HOST_SYS}-libtool
}
RRECOMMENDS_${PN} += "obexd obex-data-server"
diff --git a/recipes/gnome/gnome-bluetooth_2.32.0.bb b/recipes/gnome/gnome-bluetooth_2.32.0.bb
new file mode 100644
index 0000000000..86f5abcbd8
--- /dev/null
+++ b/recipes/gnome/gnome-bluetooth_2.32.0.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "GNOME bluetooth manager"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "gnome-doc-utils-native obexd obex-data-server gconf gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring libx11 libxi"
+
+PR = "r1"
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "f129686fe46c4c98eb70a0cc85d59cae"
+SRC_URI[archive.sha256sum] = "57b1f06c96a1b85e1c19ff919d708cc38e95edae658881ed99968c325839a973"
+
+# No 'nautilus-sendto' recipe in OE yet
+EXTRA_OECONF += "--enable-nautilus-sendto=no"
+
+# No native docbook XSL stylesheets recipe in OE yet
+do_configure_prepend() {
+ sed -i s/help// Makefile.am
+}
+
+do_configure_append() {
+ sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${HOST_SYS}-libtool
+}
+
+RRECOMMENDS_${PN} += "obexd obex-data-server"
+RCONFLICTS_${PN} = "bluez-gnome"
+
+FILES_${PN} += "${datadir}/GConf/ ${datadir}/glib-2.0/"
+FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug/"
diff --git a/recipes/gnome/gnome-control-center_2.32.1.bb b/recipes/gnome/gnome-control-center_2.32.1.bb
new file mode 100644
index 0000000000..a23f3aba02
--- /dev/null
+++ b/recipes/gnome/gnome-control-center_2.32.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "GNOME control center"
+LICENSE = "GPL"
+
+DEPENDS = "libgnomekbd gnome-menus metacity gstreamer libcanberra gnome-settings-daemon libgnomeui gnome-doc-utils gtk+ libglade libgnomecanvas librsvg libxml2 libart-lgpl atk"
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "b4e8ab5c7556ae07addbfcfb4fa2f761"
+SRC_URI[archive.sha256sum] = "7c568b57358e5c08f4d8dd76dbac7df2539135ad081872b60514b7a8ac797e66"
+
+LDFLAGS += "-lgthread-2.0 -lxml2"
+
+do_configure_prepend() {
+ sed -i s:help::g Makefile.am
+}
+
+FILES_${PN} += "${datadir}/icon* \
+ ${datadir}/xsession* \
+ ${libdir}/window-manager-settings/*.so \
+ ${datadir}/gnome \
+ ${datadir}/desktop-directories \
+ "
+FILES_${PN}-dbg += "${libdir}/window-manager-settings/.debug"
+FILES_${PN}-dev += "${libdir}/window-manager-settings/*a"
+
+
+
+
diff --git a/recipes/gnome/gnome-desktop.inc b/recipes/gnome/gnome-desktop.inc
index b96e34b76a..396f213e3d 100644
--- a/recipes/gnome/gnome-desktop.inc
+++ b/recipes/gnome/gnome-desktop.inc
@@ -3,9 +3,10 @@ SECTION = "x11/gnome"
LICENSE = "GPL"
DEPENDS = "gnome-common libgnomeui"
-PR = "r1"
+PR = "r2"
-EXTRA_OECONF = "--disable-scrollkeeper"
+# FIXME: OE does not contain all recipes to enable doc: failed to load external entity "/usr/share/xml/gnome/xslt/docbook/omf/db2omf.xsl"
+EXTRA_OECONF = "--disable-scrollkeeper --disable-gtk-doc"
do_configure_prepend () {
cp ${STAGING_DATADIR}/gnome-common/data/omf.make ${S}
diff --git a/recipes/gnome/gnome-desktop_2.32.1.bb b/recipes/gnome/gnome-desktop_2.32.1.bb
new file mode 100644
index 0000000000..ef223eaca7
--- /dev/null
+++ b/recipes/gnome/gnome-desktop_2.32.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "GNOME library for reading .desktop files"
+SECTION = "x11/gnome"
+LICENSE = "GPL"
+DEPENDS = "gnome-common libgnomeui gnome-doc-utils gnome-vfs libxrandr"
+
+inherit gnome pkgconfig
+
+SRC_URI[archive.md5sum] = "5c80d628a240eb9d9ff78913b31f2f67"
+SRC_URI[archive.sha256sum] = "55cbecf67efe1fa1e57ac966520a7c46d799c8ba3c652a1219f60cafccb3739d"
+
+EXTRA_OECONF += "--disable-desktop-docs"
+
+do_install_append() {
+ sed -i 's:#!.*/usr/bin/python:#!/usr/bin/python:' ${D}${bindir}/gnome-about
+}
+
+FILES_${PN} += "${datadir}/gnome-about ${datadir}/libgnome-desktop"
diff --git a/recipes/gnome/gnome-doc-utils.inc b/recipes/gnome/gnome-doc-utils.inc
index a1ae11e4b0..37a5f56d49 100644
--- a/recipes/gnome/gnome-doc-utils.inc
+++ b/recipes/gnome/gnome-doc-utils.inc
@@ -1,10 +1,9 @@
LICENSE = "GPL LGPL"
-DEPENDS = "libxml2 libxslt libxslt-native libxml2-native gettext-native"
-DEPENDS_virtclass-native = "libxslt-native libxml2-native gettext-native"
+DEPENDS = "libxml2 libxslt libxslt-native libxml2-native"
INC_PR = "r6"
-inherit gnomebase
+inherit gnomebase gettext
EXTRA_OECONF = "--disable-scrollkeeper"
@@ -21,4 +20,3 @@ do_install_append() {
FILES_${PN} += "${datadir}/xml*"
BBCLASSEXTEND = "native"
-
diff --git a/recipes/gnome/gnome-keyring_2.32.1.bb b/recipes/gnome/gnome-keyring_2.32.1.bb
new file mode 100644
index 0000000000..9aa4fe348b
--- /dev/null
+++ b/recipes/gnome/gnome-keyring_2.32.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GNOME security credential management"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "libgnome-keyring gtk+-native libpam gconf gtk+ libtasn1 libtasn1-native libgcrypt"
+RDEPENDS = "libgnome-keyring"
+PR = "r1"
+
+inherit gnome pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc --enable-pam --with-pam-dir=${libdir}/security"
+
+SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service file://libtool.workarround.patch"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/tasn.m4 acinclude.m4
+}
+
+do_install_append () {
+ install -d ${D}${datadir}/dbus-1/services
+ install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr ${datadir}/GConf/gsettings ${datadir}/glib-2.0/schemas"
+FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
+
+PACKAGES =+ "gnome-keyring-pam-plugin"
+FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
+
+SRC_URI[archive.md5sum] = "9a8aa74e03361676f29d6e73155786fc"
+SRC_URI[archive.sha256sum] = "31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9"
+
diff --git a/recipes/gnome/gnome-media_2.32.0.bb b/recipes/gnome/gnome-media_2.32.0.bb
new file mode 100644
index 0000000000..8a71aa23c5
--- /dev/null
+++ b/recipes/gnome/gnome-media_2.32.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "GNOME Media Tools"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "gnome-doc-utils gconf glib-2.0 gstreamer gst-plugins-base gtk+ gdk-pixbuf-csource-native libcanberra libglade libgnomeui libunique libxml2"
+# optional for volume control:
+DEPENDS += "pulseaudio"
+
+inherit gnome
+
+EXTRA_OECONF += "--disable-static --disable-gtk-doc"
+
+# FIXME: Native doc processing with xsltproc using docbook needs additional work:
+do_configure_prepend() {
+ sed -i 's/^\(SUBDIRS = .*\)\(doc\|help\)/\1/' */Makefile.am
+}
+
+FILES_${PN} += "${libdir}/libglade/2.0/libgnome-media-profiles.so \
+ ${datadir}/gstreamer-properties \
+ ${datadir}/gnome-sound-recorder"
+
+FILES_${PN}-dbg += "${libdir}/libglade/2.0/.debug"
+
+SRC_URI[archive.md5sum] = "06fc8c67add34c98bc484e0dbc404d41"
+SRC_URI[archive.sha256sum] = "2b0ad4decd75406398f46e82a170e53bcbc6e1bdc3363f03a07b00f59c2fe5e6"
+
diff --git a/recipes/gnome/gnome-menus_2.30.5.bb b/recipes/gnome/gnome-menus_2.30.5.bb
new file mode 100644
index 0000000000..c60b7c7a15
--- /dev/null
+++ b/recipes/gnome/gnome-menus_2.30.5.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "GNOME menus"
+SECTION = "x11/gnome"
+LICENSE = "GPL"
+
+DEPENDS = "python gnome-vfs libxml2 gconf popt gtk+"
+
+inherit gnome pkgconfig python-dir
+
+PACKAGES += "${PN}-python"
+FILES_${PN} += "${datadir}/desktop-directories/"
+FILES_${PN}-python = "${libdir}/python*"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug \
+ ${PYTHON_SITEPACKAGES_DIR}/.debug"
+
+SRC_URI[archive.md5sum] = "caa6772e63ed5870cf43dc3d354e0624"
+SRC_URI[archive.sha256sum] = "6dcc565006d6e8c2025ae83ab1f82edf6bd04d61c804c0dc9bf5ea50629c4caa"
+
diff --git a/recipes/gnome/gnome-nettool_2.32.0.bb b/recipes/gnome/gnome-nettool_2.32.0.bb
new file mode 100644
index 0000000000..ebb4f0b578
--- /dev/null
+++ b/recipes/gnome/gnome-nettool_2.32.0.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Gnome network tool"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "gtk+ gconf libgtop"
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "af5436deb30ccfb3f6a1f8ea5602c40d"
+SRC_URI[archive.sha256sum] = "8c70f85952760170114b2fa4be3ccaa3fc6298f802bacda2503ed482b8a0539c"
+
diff --git a/recipes/gnome/gnome-python-desktop_2.32.0.bb b/recipes/gnome/gnome-python-desktop_2.32.0.bb
new file mode 100644
index 0000000000..d5568e9616
--- /dev/null
+++ b/recipes/gnome/gnome-python-desktop_2.32.0.bb
@@ -0,0 +1,31 @@
+LICENSE = "GPL/LGPL"
+DEPENDS = "python-pycairo evince librsvg libwnck totem-pl-parser libgtop gnome-panel gnome-desktop eds-dbus python-pygtk gnome-python libgnomeprint libgnomeprintui"
+
+inherit gnome distutils-base
+
+EXTRA_OECONF += " ac_cv_path_PYGOBJECT_CODEGEN=${STAGING_DATADIR}/pygobject/2.0/codegen/codegen.py \
+ ac_cv_path_PYGTK_CODEGEN=${STAGING_DATADIR}/pygobject/2.0/codegen/codegen.py \
+ --with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ export HOST_SYS=${HOST_SYS}
+ export BUILD_SYS=${BUILD_SYS}
+ sed -i \
+ -e s:'`$PKG_CONFIG --variable defsdir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=pygtkincludedir pygobject-2.0`':\"${STAGING_INCDIR}/pygtk-2.0\":g \
+ -e s:'`$PKG_CONFIG --variable=datadir pygobject-2.0`':\"${STAGING_DATADIR}\":g \
+ -e s:'`$PKG_CONFIG --variable codegendir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
+ -e s:'`$PKG_CONFIG --variable=codegendir pygtk-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
+ -e s:'`$PKG_CONFIG --variable=fixxref pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/xsl/fixxref.py\":g \
+ -e 's:PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION":PYTHON_CFLAGS="-I${STAGING_INCDIR}/python$PYTHON_VERSION":g' \
+ -e s:'`$PKG_CONFIG --variable=defsdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g \
+ -e s:'`$PKG_CONFIG --variable=argtypesdir gnome-python-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/argtypes/\":g \
+ ${S}/configure.ac
+}
+
+FILES_${PN}-dev += "${datadir}/pygtk"
+
+SRC_URI[archive.md5sum] = "0e73fa80ace5c861777e0b523c6ead9d"
+SRC_URI[archive.sha256sum] = "09dbd580bf3b0ef60f91b090eafe6d08ddcc50a609e2b425a7f8eca46d4e0ee9"
+
diff --git a/recipes/gnome/gnome-session_2.30.2.bb b/recipes/gnome/gnome-session_2.30.2.bb
new file mode 100644
index 0000000000..0980abbc81
--- /dev/null
+++ b/recipes/gnome/gnome-session_2.30.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Gnome session manager"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "devicekit-power libwnck gnome-keyring libgnomeui startup-notification gtk+ gconf gdk-pixbuf-csource-native"
+
+inherit gnome
+
+EXTRA_OECONF = " ac_cv_path_GCONF_SANITY_CHECK=set "
+
+do_configure_append() {
+ for i in $(find ${S} -name "Makefile") ; do
+ sed -i -e s:"GCONFTOOL = .*/usr/bin/gconftool-2":"GCONFTOOL = /usr/bin/gconftool-2":g $i
+ sed -i -e s:"GCONF_SANITY_CHECK = set":"GCONF_SANITY_CHECK = /usr/libexec/gconf-sanity-check-2":g $i
+ done
+}
+
+FILES_${PN} += "${datadir}/xsessions ${datadir}/icons ${datadir}/gnome ${libdir}/gnome-session/helpers"
+FILES_${PN}-dbg += "${libexecdir}/gnome-session/helpers/.debug"
+
+SRC_URI[archive.md5sum] = "d93a2da931ac0b9c0d98f6b68a17a730"
+SRC_URI[archive.sha256sum] = "ea7b5d8b254eba0f4ee5f737ed3686fca4fa734ad54a20f206534241f6aef4ec"
+
diff --git a/recipes/gnome/gnome-system-tools_2.32.0.bb b/recipes/gnome/gnome-system-tools_2.32.0.bb
new file mode 100644
index 0000000000..cec364286c
--- /dev/null
+++ b/recipes/gnome/gnome-system-tools_2.32.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "GNOME utilities"
+SECTION = "x11/gnome"
+LICENSE = "GPL"
+DEPENDS = "policykit-gnome nautilus gnome-common glib-2.0 gtk+ gconf liboobs system-tools-backends gnome-control-center"
+inherit gnome pkgconfig
+
+SRC_URI += "file://remove-docs.patch"
+
+SRC_URI[archive.md5sum] = "93e3d21b041c771d4ac12307e4ef3392"
+SRC_URI[archive.sha256sum] = "71d52698ccb60bc07d6e4e442b7cb178ebf1152396379500df5ec62da4c4d14a"
+
+LDFLAGS += "-lgthread-2.0"
+
+FILES_${PN} += "${libdir}/nautilus/extensions-2.0 ${datadir}/glib-2.0/schemas/org.gnome.system-tools.gschema.xml"
+
+FILES_${PN}-dbg += "${libdir}/nautilus/extensions-2.0/.debug"
+
diff --git a/recipes/gnome/gnome-themes_2.32.1.bb b/recipes/gnome/gnome-themes_2.32.1.bb
new file mode 100644
index 0000000000..94d27a0fc1
--- /dev/null
+++ b/recipes/gnome/gnome-themes_2.32.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNOME themes"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = "gtk-engines icon-naming-utils-native glib-2.0 intltool-native"
+RDEPENDS_${PN} = "gnome-icon-theme"
+
+EXTRA_OECONF += "--enable-all-themes --disable-hicolor-check"
+
+inherit gnome
+
+PACKAGE_ARCH = "all"
+
+PACKAGES =+ " gnome-theme-crux gnome-theme-highcontrast gnome-theme-highcontrastinverse gnome-theme-highcontrastlargeprint gnome-theme-highcontrastlargeprintinverse gnome-theme-largeprint gnome-theme-mist"
+FILES_gnome-theme-crux = "${datadir}/themes/Crux ${datadir}/icons/Crux"
+FILES_gnome-theme-highcontrast = "${datadir}/themes/HighContrast ${datadir}/icons/HighContrast"
+FILES_gnome-theme-highcontrastinverse = "${datadir}/themes/HighContrastInverse ${datadir}/icons/HighContrastInverse"
+FILES_gnome-theme-highcontrastlargeprint = "${datadir}/themes/HighContrastLargePrint ${datadir}/icons/HighContrastLargePrint"
+FILES_gnome-theme-highcontrastlargeprintinverse = "${datadir}/themes/HighContrastLargePrintInverse ${datadir}/icons/HighContrastLargePrintInverse"
+FILES_gnome-theme-largeprint = "${datadir}/themes/LargePrint ${datadir}/icons/LargePrint"
+FILES_gnome-theme-mist = "${datadir}/themes/Mist ${datadir}/icons/Mist"
+
+FILES_${PN} += "${datadir}/themes ${datadir}/icons"
+
+SRC_URI[archive.md5sum] = "41db9e3cb25d35af2675c599e67944d1"
+SRC_URI[archive.sha256sum] = "8601ee24c2e096593221cbd6ebdb6686042225a03c02a01c0d67c163f9febd1a"
+
diff --git a/recipes/gnome/gnome-utils_2.32.0.bb b/recipes/gnome/gnome-utils_2.32.0.bb
new file mode 100644
index 0000000000..27e6040c76
--- /dev/null
+++ b/recipes/gnome/gnome-utils_2.32.0.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "GNOME utilities"
+SECTION = "x11/gnome"
+LICENSE = "GPL"
+DEPENDS = "gnome-common glib-2.0 gtk+ gconf"
+
+inherit gnome pkgconfig
+
+SRC_URI += "file://no-try-run-strftime.diff"
+
+SRC_URI[archive.md5sum] = "e150cdb53314fe97ea80768850c2e03c"
+SRC_URI[archive.sha256sum] = "033a55cf442096b28ea6292043354feafe000d1e5f4ebb962a9b6d72eb9a93fa"
+
+do_configure_append() {
+ for i in $(find ${S} -name "Makefile") ; do
+ sed -i -e s:-Werror::g $i
+ done
+
+ for i in ${S}/*/Makefile.am ; do
+ sed -i -e 's: help::g' $i
+ done
+}
+
+FILES_${PN} += "${datadir}/baobab \
+ ${datadir}/gdict-1.0 \
+ ${datadir}/gnome-dictionary \
+ ${datadir}/gnome-screenshot \
+ "
+
+
diff --git a/recipes/gnome/gsettings-desktop-schemas_3.0.0.bb b/recipes/gnome/gsettings-desktop-schemas_3.0.0.bb
new file mode 100644
index 0000000000..205fe59ed9
--- /dev/null
+++ b/recipes/gnome/gsettings-desktop-schemas_3.0.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Gnome desktop schemas"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = ""
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "227f020980c746fbf4da21991b107184"
+SRC_URI[archive.sha256sum] = "1b8d7f6141379f3ab58ca917baa3eb947e78d6425664b21dc199a35f99991af6"
+
+FILES_${PN} += " \
+ ${datadir}/GConf/ \
+ ${datadir}/glib-2.0/schemas/ \
+ "
+
diff --git a/recipes/gnome/libgnome-keyring_2.32.0.bb b/recipes/gnome/libgnome-keyring_2.32.0.bb
new file mode 100644
index 0000000000..a3f47da4a3
--- /dev/null
+++ b/recipes/gnome/libgnome-keyring_2.32.0.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Gnome keyring library"
+LICENSE = "GPL"
+SECTION = "x11/gnome"
+DEPENDS = ""
+
+inherit gnome lib_package
+
+SRC_URI[archive.md5sum] = "c42b2ca66204835d901d3dbfc1fa5ae6"
+SRC_URI[archive.sha256sum] = "56388c0d81ddfdb57d30e4963c83ecc1c18498aab99395420e0fff69929a0f0c"
+
diff --git a/recipes/gnome/libgnome_2.32.1.bb b/recipes/gnome/libgnome_2.32.1.bb
new file mode 100644
index 0000000000..3eebdb9007
--- /dev/null
+++ b/recipes/gnome/libgnome_2.32.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Gnome application programming libraries"
+LICENSE = "GPL"
+SECTION = "x11/gnome/libs"
+
+inherit gnome lib_package
+
+SRC_URI[archive.md5sum] = "a4345e6087ae6195d65a4674ffdca559"
+SRC_URI[archive.sha256sum] = "b2c63916866485793b87398266dd7778548c1734923c272a94d84ee011b6f7a4"
+
+DEPENDS += "libcanberra gconf-native gnome-vfs libbonobo esound"
+
+EXTRA_OECONF += "--disable-gtk-doc"
+
+do_configure_prepend() {
+ sed -i -e s:docs::g ${S}/Makefile.am
+ echo "EXTRA_DIST = version.xml" > gnome-doc-utils.make
+ echo "EXTRA_DIST = version.xml" > gtk-doc.make
+}
+
+FILES_${PN} += "${libdir}/bonobo/servers ${libdir}/bonobo/monikers/*.so \
+ ${datadir}/gnome-background-properties ${datadir}/pixmaps"
+FILES_${PN}-dev += "${libdir}/bonobo/monikers/*a"
+FILES_${PN}-dbg += "${libdir}/bonobo/monikers/.debug"
+
diff --git a/recipes/gnome/libgnomekbd_2.32.0.bb b/recipes/gnome/libgnomekbd_2.32.0.bb
new file mode 100644
index 0000000000..7696365ee4
--- /dev/null
+++ b/recipes/gnome/libgnomekbd_2.32.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "GNOME keyboard library"
+LICENSE = "LGPL"
+SECTION = "x11/gnome/libs"
+
+DEPENDS = "gconf libgnome libxklavier"
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "de32a6e3e3464b566eecdc4332bf34bd"
+SRC_URI[archive.sha256sum] = "ddd52c4cc7d83ad7ef964a1bcb4db87407e65b00ffc3e70c088ca4ee7383d256"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+
+
+
+
diff --git a/recipes/gnome/liboobs_2.32.0.bb b/recipes/gnome/liboobs_2.32.0.bb
new file mode 100644
index 0000000000..dbeda8167e
--- /dev/null
+++ b/recipes/gnome/liboobs_2.32.0.bb
@@ -0,0 +1,9 @@
+LICENSE = "LGPL"
+DEPENDS = "glib-2.0 dbus system-tools-backends"
+
+inherit gnome lib_package
+
+SRC_URI[archive.md5sum] = "0bb40041b7227f9060ab51f3022115df"
+SRC_URI[archive.sha256sum] = "1b70061272b2c777d505b5b6c785e045d4297639dd0d4214d04dea154a9b63d6"
+
+
diff --git a/recipes/gnome/libwnck/introspection.patch b/recipes/gnome/libwnck/introspection.patch
deleted file mode 100644
index 0c0c24fb99..0000000000
--- a/recipes/gnome/libwnck/introspection.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: libwnck-2.30.5/configure.ac
-===================================================================
---- libwnck-2.30.5.orig/configure.ac 2012-07-02 05:17:34.118158298 -0700
-+++ libwnck-2.30.5/configure.ac 2012-07-02 05:23:19.071869288 -0700
-@@ -167,7 +167,7 @@
- ##################################################
- GTK_DOC_CHECK([1.9])
-
--GOBJECT_INTROSPECTION_CHECK([0.6.14])
-+AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
-
- AC_OUTPUT([
- Makefile
diff --git a/recipes/gnome/libwnck_2.30.5.bb b/recipes/gnome/libwnck_2.30.5.bb
index fa3c0cecb3..6a981a319b 100644
--- a/recipes/gnome/libwnck_2.30.5.bb
+++ b/recipes/gnome/libwnck_2.30.5.bb
@@ -1,13 +1,14 @@
DESCRIPTION = "Window navigation construction toolkit"
LICENSE = "LGPL"
SECTION = "x11/libs"
-DEPENDS = "gtk+ gtk+-native"
-PR = "r1"
-inherit gnome
-
-SRC_URI += "file://introspection.patch"
+DEPENDS = "gobject-introspection-native gtk+ gtk+-native"
+inherit gnome
SRC_URI[archive.md5sum] = "4162d5b96151e6d24ec02ae3a822203c"
SRC_URI[archive.sha256sum] = "56b6681e89cd45491bb640165d62276d81369a08974042b26645dc1e0e954cc1"
EXTRA_OECONF += "--enable-introspection=no"
+
+do_configure_prepend() {
+ sed -i '/GOBJECT_INTROSPECTION_CHECK([0.6.14])/d' configure.ac
+}
diff --git a/recipes/gnome/system-tools-backends_2.10.1.bb b/recipes/gnome/system-tools-backends_2.10.1.bb
index bac0a9cb16..225c5daeba 100644
--- a/recipes/gnome/system-tools-backends_2.10.1.bb
+++ b/recipes/gnome/system-tools-backends_2.10.1.bb
@@ -32,7 +32,7 @@ do_configure() {
aclocal
gnu-configize
oe_runconf
- cp ${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool ${S}
+ cp ${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool ${S}
}
do_install_append () {
diff --git a/recipes/gnome/zenity_2.28.0.bb b/recipes/gnome/zenity_2.28.0.bb
index 65643aed10..a5a5a1b110 100644
--- a/recipes/gnome/zenity_2.28.0.bb
+++ b/recipes/gnome/zenity_2.28.0.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "A tool to display dialogs from the command line and shell scripts."
LICENSE = "GPL"
-DEPENDS = "gtk+ libglade glib-2.0 libnotify"
+DEPENDS = "gtk+ libglade glib-2.0 libnotify gnome-doc-utils"
inherit gnome