aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnuchess/gnuchess_5.021.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnuchess/gnuchess_5.021.bb')
-rw-r--r--recipes/gnuchess/gnuchess_5.021.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/recipes/gnuchess/gnuchess_5.021.bb b/recipes/gnuchess/gnuchess_5.021.bb
index 18c94bdab0..8d1afea1bf 100644
--- a/recipes/gnuchess/gnuchess_5.021.bb
+++ b/recipes/gnuchess/gnuchess_5.021.bb
@@ -3,11 +3,23 @@ SECTION = "console"
PRIORITY = "optional"
MAINTAINER = "Andreas Holzer <a.holzer@cheese.at>"
LICENSE = "GPL"
-SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz"
+PR = "r1"
+RSUGGESTS_${PN} = "xboard"
+SRC_URI = "http://members.cheese.at/woody/fltk-chess/gnuchess_5.02.tar.gz \
+ file://gnuchess.desktop \
+ file://gnuchess.png \
+ file://gnuchess.sh \
+"
S = "${WORKDIR}/chess-5.02/src"
inherit autotools
do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/pixmaps/
+ install -d ${D}${datadir}/applications/
+ install -m 0755 ${WORKDIR}/gnuchess.sh ${D}${bindir}
+ install -m 0644 ${WORKDIR}/gnuchess.png ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/gnuchess.desktop ${D}${datadir}/applications/
install -D ${S}/gnuchess ${D}${bindir}/gnuchess
}