aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnuradio/gnuradio-git
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnuradio/gnuradio-git')
-rw-r--r--recipes/gnuradio/gnuradio-git/0001-Brute-force-selection-of-moc-and-uic.patch28
-rw-r--r--recipes/gnuradio/gnuradio-git/0001-Diable-checks-for-PyQT-and-PyQWT.patch40
-rw-r--r--recipes/gnuradio/gnuradio-git/0001-Disable-python-checks-so-grc-builds.patch32
-rw-r--r--recipes/gnuradio/gnuradio-git/0001-Remove-all-traces-of-volk-from-configure-again.patch50
4 files changed, 150 insertions, 0 deletions
diff --git a/recipes/gnuradio/gnuradio-git/0001-Brute-force-selection-of-moc-and-uic.patch b/recipes/gnuradio/gnuradio-git/0001-Brute-force-selection-of-moc-and-uic.patch
new file mode 100644
index 0000000000..d49a358d5b
--- /dev/null
+++ b/recipes/gnuradio/gnuradio-git/0001-Brute-force-selection-of-moc-and-uic.patch
@@ -0,0 +1,28 @@
+From 031799e43c853d7723230be57ddacbf10d975cde Mon Sep 17 00:00:00 2001
+From: Philip Balister <philip@opensdr.com>
+Date: Tue, 1 Nov 2011 09:06:16 -0400
+Subject: [PATCH] Brute force selection of moc and uic.
+
+Signed-off-by: Philip Balister <philip@opensdr.com>
+---
+ config/grc_gr_qtgui.m4 | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/config/grc_gr_qtgui.m4 b/config/grc_gr_qtgui.m4
+index 0efd7c8..bc50cac 100644
+--- a/config/grc_gr_qtgui.m4
++++ b/config/grc_gr_qtgui.m4
+@@ -67,8 +67,8 @@ dnl [PyQt4.Qwt5.QWT_VERSION >= 327000])
+ QMAKE_INCLUDES="$QMAKE_INCLUDES ${i##-I}"
+ done
+
+- QT_MOC_EXEC=`pkg-config --variable=moc_location QtCore`
+- QT_UIC_EXEC=`pkg-config --variable=uic_location QtCore`
++ QT_MOC_EXEC=moc
++ QT_UIC_EXEC=uic
+
+ gr_qtgui_INCLUDES="\
+ -I\${abs_top_srcdir}/gr-qtgui/include \
+--
+1.7.6.4
+
diff --git a/recipes/gnuradio/gnuradio-git/0001-Diable-checks-for-PyQT-and-PyQWT.patch b/recipes/gnuradio/gnuradio-git/0001-Diable-checks-for-PyQT-and-PyQWT.patch
new file mode 100644
index 0000000000..1fb7c3243f
--- /dev/null
+++ b/recipes/gnuradio/gnuradio-git/0001-Diable-checks-for-PyQT-and-PyQWT.patch
@@ -0,0 +1,40 @@
+From 04316ec0cfa5003b4777299200465fc47680e6e3 Mon Sep 17 00:00:00 2001
+From: Philip Balister <philip@opensdr.com>
+Date: Tue, 1 Nov 2011 07:31:46 -0400
+Subject: [PATCH] Diable checks for PyQT and PyQWT.
+
+They are need at runtime not build time. This should let us build gnuradio
+qt support, without needing to cross build PyQt and PyQwt.
+
+Signed-off-by: Philip Balister <philip@opensdr.com>
+---
+ config/grc_gr_qtgui.m4 | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/config/grc_gr_qtgui.m4 b/config/grc_gr_qtgui.m4
+index d9e0fcb..0efd7c8 100644
+--- a/config/grc_gr_qtgui.m4
++++ b/config/grc_gr_qtgui.m4
+@@ -28,13 +28,13 @@ AC_DEFUN([GRC_GR_QTGUI],[
+ dnl yes : if the --enable code passed muster and all dependencies are met
+ dnl no : otherwise
+
+- PYTHON_CHECK_MODULE([PyQt4.QtCore], [PyQt4 for Qt4], \
+- [], [passed=no], \
+- [PyQt4.QtCore.PYQT_VERSION >= 260000])
++dnl PYTHON_CHECK_MODULE([PyQt4.QtCore], [PyQt4 for Qt4], \
++dnl [], [passed=no], \
++dnl [PyQt4.QtCore.PYQT_VERSION >= 260000])
+
+- PYTHON_CHECK_MODULE([PyQt4.Qwt5], [PyQwt5 for Qt4], \
+- [], [passed=no], \
+- [PyQt4.Qwt5.QWT_VERSION >= 327000])
++dnl PYTHON_CHECK_MODULE([PyQt4.Qwt5], [PyQwt5 for Qt4], \
++dnl [], [passed=no], \
++dnl [PyQt4.Qwt5.QWT_VERSION >= 327000])
+
+ # Check for:
+ # QtOpenGL
+--
+1.7.6.4
+
diff --git a/recipes/gnuradio/gnuradio-git/0001-Disable-python-checks-so-grc-builds.patch b/recipes/gnuradio/gnuradio-git/0001-Disable-python-checks-so-grc-builds.patch
new file mode 100644
index 0000000000..5381b0ace3
--- /dev/null
+++ b/recipes/gnuradio/gnuradio-git/0001-Disable-python-checks-so-grc-builds.patch
@@ -0,0 +1,32 @@
+From 7ed8556541d29a54a6d47e5156f42002e6051f0b Mon Sep 17 00:00:00 2001
+From: Philip Balister <philip@opensdr.com>
+Date: Tue, 1 Nov 2011 14:16:59 -0400
+Subject: [PATCH] Disable python checks so grc builds.
+
+Signed-off-by: Philip Balister <philip@opensdr.com>
+---
+ config/grc_grc.m4 | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/config/grc_grc.m4 b/config/grc_grc.m4
+index 0474c4e..c17df7a 100644
+--- a/config/grc_grc.m4
++++ b/config/grc_grc.m4
+@@ -28,10 +28,10 @@ AC_DEFUN([GRC_GRC],[
+ dnl ########################################
+ if test $passed = yes; then
+ PYTHON_CHECK_MODULE([sys],[Python >= 2.5],[],[passed=no],[sys.version.split()[[0]] >= "2.5"])
+- PYTHON_CHECK_MODULE([Cheetah],[Python Cheetah templates >= 2.0.0],[],[passed=no],[Cheetah.Version >= "2.0.0"])
+- PYTHON_CHECK_MODULE([lxml.etree],[Python lxml wrappers >= 1.3.6],[],[passed=no],[lxml.etree.LXML_VERSION >= (1, 3, 6, 0)])
+- PYTHON_CHECK_MODULE([gtk],[Python gtk wrappers >= 2.10.0],[],[passed=no],[gtk.pygtk_version >= (2, 10, 0)])
+- PYTHON_CHECK_MODULE([numpy],[NumPy],[],[passed=no],[True])
++dnl PYTHON_CHECK_MODULE([Cheetah],[Python Cheetah templates >= 2.0.0],[],[passed=no],[Cheetah.Version >= "2.0.0"])
++dnl PYTHON_CHECK_MODULE([lxml.etree],[Python lxml wrappers >= 1.3.6],[],[passed=no],[lxml.etree.LXML_VERSION >= (1, 3, 6, 0)])
++dnl PYTHON_CHECK_MODULE([gtk],[Python gtk wrappers >= 2.10.0],[],[passed=no],[gtk.pygtk_version >= (2, 10, 0)])
++dnl PYTHON_CHECK_MODULE([numpy],[NumPy],[],[passed=no],[True])
+ fi
+
+ AC_CONFIG_FILES([ \
+--
+1.7.6.4
+
diff --git a/recipes/gnuradio/gnuradio-git/0001-Remove-all-traces-of-volk-from-configure-again.patch b/recipes/gnuradio/gnuradio-git/0001-Remove-all-traces-of-volk-from-configure-again.patch
new file mode 100644
index 0000000000..9cfc41642d
--- /dev/null
+++ b/recipes/gnuradio/gnuradio-git/0001-Remove-all-traces-of-volk-from-configure-again.patch
@@ -0,0 +1,50 @@
+From a772f928693476297fe907d5de414516c58f2a51 Mon Sep 17 00:00:00 2001
+From: Philip Balister <philip@opensdr.com>
+Date: Tue, 1 Nov 2011 07:46:30 -0400
+Subject: [PATCH] Remove all traces of volk from configure again.
+
+Signed-off-by: Philip Balister <philip@opensdr.com>
+---
+ Makefile.common | 6 +-----
+ configure.ac | 1 -
+ 2 files changed, 1 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.common b/Makefile.common
+index a4d5817..2cea092 100644
+--- a/Makefile.common
++++ b/Makefile.common
+@@ -59,7 +59,7 @@ grpyexecdir = $(pyexecdir)/gnuradio
+ # This used to be set in configure.ac but is now defined here for all
+ # Makefiles when this fragment is included.
+ STD_DEFINES_AND_INCLUDES = $(DEFINES) $(GNURADIO_INCLUDES) \
+- $(GRUEL_INCLUDES) $(VOLK_INCLUDES) $(BOOST_CPPFLAGS)
++ $(GRUEL_INCLUDES) $(BOOST_CPPFLAGS)
+
+ # when including for compilation from pre-installed libraries and such,
+ # need to make sure those are put last on the compile command
+@@ -77,10 +77,6 @@ GNURADIO_CORE_LA = @gnuradio_core_LA@
+ GRUEL_INCLUDES = @gruel_INCLUDES@
+ GRUEL_LA = @gruel_LA@
+
+-# How to link in the VOLK library from inside the tree
+-VOLK_INCLUDES = @volk_INCLUDES@
+-VOLK_LA = @volk_LA@
+-
+ # GR-DIGITAL includes and libraries
+ GR_DIGITAL_INCLUDES = @gr_digital_INCLUDES@
+ GR_DIGITAL_LA = @gr_digital_LA@
+diff --git a/configure.ac b/configure.ac
+index 432c398..f27de88 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -349,7 +349,6 @@ AC_ARG_ENABLE(
+
+ build_dirs="config"
+ GRC_GRUEL dnl must come first
+-GRC_VOLK
+ GRC_GNURADIO_CORE
+ GRC_GR_DIGITAL
+ GRC_GR_AUDIO
+--
+1.7.6.4
+