aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnuradio/gnuradio_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gnuradio/gnuradio_svn.bb')
-rw-r--r--recipes/gnuradio/gnuradio_svn.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gnuradio/gnuradio_svn.bb b/recipes/gnuradio/gnuradio_svn.bb
new file mode 100644
index 0000000000..56db9187c4
--- /dev/null
+++ b/recipes/gnuradio/gnuradio_svn.bb
@@ -0,0 +1,29 @@
+require gnuradio.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+DEPENDS += " gsl "
+
+PV = "3.1.3+svnr${SRCREV}"
+PR = "r6"
+
+EXTRA_OECONF += "--with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable-usrp1 --disable--usrp2"
+
+SRC_URI = "svn://gnuradio.org/svn/gnuradio/;module=trunk;proto=http \
+ file://no-usrp2.patch;patch=1 \
+ file://gnuradio-neon.patch;patch=1;pnum=0 \
+ "
+
+S="${WORKDIR}/trunk"
+
+#do_configure() {
+# ./bootstrap
+# oe_runconf
+#}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ gnuradio-core/gnuradio-core.pc
+}
+