aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gobby/obby_0.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gobby/obby_0.4.1.bb')
-rw-r--r--recipes/gobby/obby_0.4.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/gobby/obby_0.4.1.bb b/recipes/gobby/obby_0.4.1.bb
new file mode 100644
index 0000000000..f72ca51ab3
--- /dev/null
+++ b/recipes/gobby/obby_0.4.1.bb
@@ -0,0 +1,18 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+
+DEPENDS = "net6 gtkmm gmp"
+inherit autotools pkgconfig
+
+SRC_URI = "http://releases.0x539.de/obby/obby-${PV}.tar.gz"
+
+EXTRA_OECONF += " --with-libgmp-prefix=${STAGING_LIBDIR}"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/obby
+ install -d ${STAGING_INCDIR}/obby/serialise
+ install -m 644 inc/*.hpp ${STAGING_INCDIR}/obby
+ install -m 644 inc/serialise/*.hpp ${STAGING_INCDIR}/obby/serialise
+ install -m 755 src/.libs/*so* ${STAGING_LIBDIR}/
+}