aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-announce
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-announce')
-rw-r--r--recipes/gpe-announce/files/fix-install.diff13
-rw-r--r--recipes/gpe-announce/gpe-announce_0.13.bb5
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/gpe-announce/files/fix-install.diff b/recipes/gpe-announce/files/fix-install.diff
new file mode 100644
index 0000000000..3827f5562a
--- /dev/null
+++ b/recipes/gpe-announce/files/fix-install.diff
@@ -0,0 +1,13 @@
+diff --git gpe-announce-0.13/Makefile-orig gpe-announce-0.13/Makefile
+index 56e016a..f8bade4 100644
+--- gpe-announce-0.13/Makefile-orig
++++ gpe-announce-0.13/Makefile
+@@ -47,7 +47,7 @@ $(PACKAGE): $(OBJS)
+
+ install-program: all
+ install -d $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+
+ clean:
+ rm -f $(PACKAGE) $(OBJS) $(DEPS)
diff --git a/recipes/gpe-announce/gpe-announce_0.13.bb b/recipes/gpe-announce/gpe-announce_0.13.bb
index 6ffe317a12..21538c43a7 100644
--- a/recipes/gpe-announce/gpe-announce_0.13.bb
+++ b/recipes/gpe-announce/gpe-announce_0.13.bb
@@ -4,4 +4,7 @@ DEPENDS = "libsoundgen libschedule gtk+ libgpewidget"
LICENSE = "GPL"
PR = "r1"
-SRC_URI += "file://fix-esound.diff;patch=1"
+SRC_URI += " \
+ file://fix-esound.diff;patch=1 \
+ file://fix-install.diff;patch=1 \
+ "