summaryrefslogtreecommitdiffstats
path: root/recipes/gpe-calculator
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-calculator')
-rw-r--r--recipes/gpe-calculator/gpe-calculator-0.2/fix_makefile.patch47
-rw-r--r--recipes/gpe-calculator/gpe-calculator_0.2.bb9
2 files changed, 56 insertions, 0 deletions
diff --git a/recipes/gpe-calculator/gpe-calculator-0.2/fix_makefile.patch b/recipes/gpe-calculator/gpe-calculator-0.2/fix_makefile.patch
new file mode 100644
index 0000000000..b8c6d1a960
--- /dev/null
+++ b/recipes/gpe-calculator/gpe-calculator-0.2/fix_makefile.patch
@@ -0,0 +1,47 @@
+diff -urNd ../gpe-calculator-0.2-r0/gpe-calculator-0.2/Makefile gpe-calculator-0.2/Makefile
+--- ../gpe-calculator-0.2-r0/gpe-calculator-0.2/Makefile 2004-08-03 04:24:09.000000000 +0100
++++ gpe-calculator-0.2/Makefile 2004-08-03 13:12:48.000000000 +0100
+@@ -9,17 +9,17 @@
+ GTKCFLAGS = `pkg-config --cflags gtk+-2.0` -DGTK_ENABLE_BROKEN
+ GTKLDFLAGS += `pkg-config --libs gtk+-2.0`
+
+-CPPFLAGS = -D_GNU_SOURCE
++PACKAGE_CPPFLAGS = -D_GNU_SOURCE
+ ifeq ($(DEBUG),yes)
+-CFLAGS += -O2 -g
+-LDFLAGS = -g #-lefence
++PACKAGE_CFLAGS += -O2 -g
++PACKAGE_LDFLAGS = -g #-lefence
+ else
+-CFLAGS += -Os -fomit-frame-pointer
++PACKAGE_CFLAGS += -Os -fomit-frame-pointer
+ endif
+-CFLAGS += -Wall $(GTKCFLAGS)
+-LDFLAGS += $(GTKLDFLAGS)
+-CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\" -DPACKAGE_DATA_DIR=\"$(PREFIX)/share\"
+-CFLAGS += -MD
++PACKAGE_CFLAGS += -Wall $(GTKCFLAGS)
++PACKAGE_LDFLAGS += $(GTKLDFLAGS)
++PACKAGE_CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\" -DPACKAGE_DATA_DIR=\"$(PREFIX)/share\"
++PACKAGE_CFLAGS += -MD
+
+ .SUFFIXES: .d
+
+@@ -36,14 +36,15 @@
+ all: $(PACKAGE)
+
+ $(PACKAGE): $(OBJS)
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS)
+
+ install-program: all
+ install -D $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ install -D -m 644 $(PACKAGE).png $(DESTDIR)$(PREFIX)/share/pixmaps/$(PACKAGE).png
+ mkdir -p $(DESTDIR)$(PREFIX)/share/applications
+ install -m 644 $(PACKAGE).desktop $(DESTDIR)$(PREFIX)/share/applications
+- strip $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+
+ clean:
+ rm -f $(PACKAGE) $(OBJS) $(DEPS)
diff --git a/recipes/gpe-calculator/gpe-calculator_0.2.bb b/recipes/gpe-calculator/gpe-calculator_0.2.bb
new file mode 100644
index 0000000000..912d14ab73
--- /dev/null
+++ b/recipes/gpe-calculator/gpe-calculator_0.2.bb
@@ -0,0 +1,9 @@
+inherit gpe pkgconfig
+
+DESCRIPTION = "A scientific calculator"
+DEPENDS = "gtk+ libgpewidget"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI += "file://fix_makefile.patch;patch=1"