aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-clock/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-clock/files')
-rw-r--r--recipes/gpe-clock/files/fix-install.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/gpe-clock/files/fix-install.patch b/recipes/gpe-clock/files/fix-install.patch
new file mode 100644
index 0000000000..2d3e3032d0
--- /dev/null
+++ b/recipes/gpe-clock/files/fix-install.patch
@@ -0,0 +1,13 @@
+diff --git gpe-clock-0.25/Makefile-orig gpe-clock-0.25/Makefile
+index 4fa59bf..e716fcb 100644
+--- gpe-clock-0.25/Makefile-orig
++++ gpe-clock-0.25/Makefile
+@@ -36,7 +36,7 @@ $(PACKAGE): $(OBJS)
+
+ install-program: all
+ install -d $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ install -d $(DESTDIR)$(PREFIX)/share/pixmaps
+ install -m 644 $(PACKAGE).png $(DESTDIR)$(PREFIX)/share/pixmaps/
+ install -d $(DESTDIR)$(PREFIX)/share/applications