aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-conf/gpe-conf_0.2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-conf/gpe-conf_0.2.8.bb')
-rw-r--r--recipes/gpe-conf/gpe-conf_0.2.8.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/gpe-conf/gpe-conf_0.2.8.bb b/recipes/gpe-conf/gpe-conf_0.2.8.bb
new file mode 100644
index 0000000000..de840517e6
--- /dev/null
+++ b/recipes/gpe-conf/gpe-conf_0.2.8.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Configuration applets for GPE"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "gtk+ esound audiofile libgpewidget libxsettings libxsettings-client libxrandr"
+RDEPENDS_${PN} = "xst gpe-confd xset ntpdate gpe-icons tzdata xrandr"
+RDEPENDS_gpe-conf-panel = "gpe-conf"
+
+RPROVIDES_${PN} += " bl"
+RCONFLICTS_${PN} = "bl"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe autotools pkgconfig
+
+PACKAGES += "gpe-conf-panel"
+
+FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
+ ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
+ ${datadir}/gpe-conf"
+FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
+