aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-edit
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-edit')
-rw-r--r--recipes/gpe-edit/gpe-edit/desktop-categories.patch9
-rw-r--r--recipes/gpe-edit/gpe-edit/toolbar.patch7
-rw-r--r--recipes/gpe-edit/gpe-edit_0.29.bb7
-rw-r--r--recipes/gpe-edit/gpe-edit_0.31.bb7
-rw-r--r--recipes/gpe-edit/gpe-edit_0.32.bb8
-rw-r--r--recipes/gpe-edit/gpe-edit_0.40.bb8
-rw-r--r--recipes/gpe-edit/gpe-edit_svn.bb12
7 files changed, 58 insertions, 0 deletions
diff --git a/recipes/gpe-edit/gpe-edit/desktop-categories.patch b/recipes/gpe-edit/gpe-edit/desktop-categories.patch
new file mode 100644
index 0000000000..d0453914f6
--- /dev/null
+++ b/recipes/gpe-edit/gpe-edit/desktop-categories.patch
@@ -0,0 +1,9 @@
+--- gpe-edit-0.23/gpe-edit.desktop.in.old 2004-08-03 15:40:26.000000000 +0100
++++ gpe-edit-0.23/gpe-edit.desktop.in 2004-08-03 15:40:32.000000000 +0100
+@@ -5,5 +5,5 @@
+ Terminal=0
+ Type=Application
+ Icon=gpe-edit.png
+-Categories=Application;Utility;GPE
++Categories=Application;Utility;GPE;Office;
+ StartupNotify=True
diff --git a/recipes/gpe-edit/gpe-edit/toolbar.patch b/recipes/gpe-edit/gpe-edit/toolbar.patch
new file mode 100644
index 0000000000..3a1eb85405
--- /dev/null
+++ b/recipes/gpe-edit/gpe-edit/toolbar.patch
@@ -0,0 +1,7 @@
+Index: main.c
+===================================================================
+RCS file: /cvs/gpe/base/gpe-edit/main.c,v
+retrieving revision 1.46
+diff -r1.46 main.c
+582d581
+< gtk_toolbar_set_style (GTK_TOOLBAR (toolbar), GTK_TOOLBAR_ICONS);
diff --git a/recipes/gpe-edit/gpe-edit_0.29.bb b/recipes/gpe-edit/gpe-edit_0.29.bb
new file mode 100644
index 0000000000..f4089be7ff
--- /dev/null
+++ b/recipes/gpe-edit/gpe-edit_0.29.bb
@@ -0,0 +1,7 @@
+LICENSE = "GPL"
+inherit gpe
+
+DEPENDS = "gtk+ libdisplaymigration libgpewidget"
+SECTION = "gpe"
+DESCRIPTION = "Editor for the GPE Palmtop Environment"
+
diff --git a/recipes/gpe-edit/gpe-edit_0.31.bb b/recipes/gpe-edit/gpe-edit_0.31.bb
new file mode 100644
index 0000000000..a7c688a5d9
--- /dev/null
+++ b/recipes/gpe-edit/gpe-edit_0.31.bb
@@ -0,0 +1,7 @@
+LICENSE = "GPL"
+inherit gpe
+
+DEPENDS = "gtk+ libgpewidget"
+SECTION = "gpe"
+DESCRIPTION = "Editor for the GPE Palmtop Environment"
+
diff --git a/recipes/gpe-edit/gpe-edit_0.32.bb b/recipes/gpe-edit/gpe-edit_0.32.bb
new file mode 100644
index 0000000000..db15a3d7b6
--- /dev/null
+++ b/recipes/gpe-edit/gpe-edit_0.32.bb
@@ -0,0 +1,8 @@
+SECTION = "gpe"
+DESCRIPTION = "Editor for the GPE Palmtop Environment"
+LICENSE = "GPL"
+PR = "r1"
+
+DEPENDS = "gtk+ libgpewidget"
+
+inherit gpe
diff --git a/recipes/gpe-edit/gpe-edit_0.40.bb b/recipes/gpe-edit/gpe-edit_0.40.bb
new file mode 100644
index 0000000000..a3e9a8b71a
--- /dev/null
+++ b/recipes/gpe-edit/gpe-edit_0.40.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Editor for the GPE Palmtop Environment"
+SECTION = "gpe"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libgpewidget"
+
+GPE_TARBALL_SUFFIX ?= "bz2"
+
+inherit gpe autotools
diff --git a/recipes/gpe-edit/gpe-edit_svn.bb b/recipes/gpe-edit/gpe-edit_svn.bb
new file mode 100644
index 0000000000..780294bd13
--- /dev/null
+++ b/recipes/gpe-edit/gpe-edit_svn.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Editor for the GPE Palmtop Environment"
+SECTION = "gpe"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libgpewidget"
+
+inherit gpe autotools
+
+SRC_URI = "${GPE_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+DEFAULT_PREFERENCE = "-1"