summaryrefslogtreecommitdiffstats
path: root/recipes/gpe-login/gpe-login_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-login/gpe-login_svn.bb')
-rw-r--r--recipes/gpe-login/gpe-login_svn.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/gpe-login/gpe-login_svn.bb b/recipes/gpe-login/gpe-login_svn.bb
new file mode 100644
index 0000000000..f02e095698
--- /dev/null
+++ b/recipes/gpe-login/gpe-login_svn.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "GPE user login screen"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libgpewidget gpe-ownerinfo xkbd"
+RDEPENDS = "xkbd"
+RPROVIDES_${PN} = "gpe-session-starter"
+PV = "0.93+svn${SRCDATE}"
+
+inherit autotools
+
+SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"
+
+SRC_URI = "${GPE_SVN} \
+ file://removeblue-fontsize8.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+CONFFILES_${PN} += " \
+${sysconfdir}/apm/suspend.d/S98lock-display \
+${sysconfdir}/gpe/gpe-login.conf \
+${sysconfdir}/gpe/locale.alias \
+${sysconfdir}/sysconfig/gpelogin \
+${sysconfdir}/X11/gpe-login.keylaunchrc \
+${sysconfdir}/X11/gpe-login.gtkrc \
+${sysconfdir}/X11/gpe-login.setup \
+${sysconfdir}/X11/gpe-login.pre-session \
+${sysconfdir}/X11/Xinit.d/99gpe-login \
+${sysconfdir}/X11/Xsession.d/50autolock \
+"
+
+
+DEFAULT_PREFERENCE = "-1"