aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-package/gpe-package_0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-package/gpe-package_0.3.bb')
-rw-r--r--recipes/gpe-package/gpe-package_0.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/gpe-package/gpe-package_0.3.bb b/recipes/gpe-package/gpe-package_0.3.bb
new file mode 100644
index 0000000000..1ee7a9a2ff
--- /dev/null
+++ b/recipes/gpe-package/gpe-package_0.3.bb
@@ -0,0 +1,23 @@
+LICENSE = "GPL"
+PR = "r3"
+inherit gpe pkgconfig
+
+DESCRIPTION = "A package manager GUI for GPE"
+DEPENDS = "ipkg libpcre libgpewidget"
+RDEPENDS = "gpe-icons gpe-su"
+SECTION = "gpe"
+PRIORITY = "optional"
+
+SRC_URI += " file://sbin-and-no-suid-install.patch;patch=1 \
+ file://search.patch;patch=1 \
+ file://gpe-package"
+
+FILES_${PN} += " /usr/bin/gpe-package"
+
+CFLAGS += "-DENABLE_PCRE"
+LDFLAGS += "-lpcre"
+
+do_install_append() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/gpe-package ${D}${bindir}
+}