summaryrefslogtreecommitdiffstats
path: root/recipes/gpe-soundbite
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-soundbite')
-rw-r--r--recipes/gpe-soundbite/files/makefile-fix.patch11
-rw-r--r--recipes/gpe-soundbite/gpe-soundbite_1.0.6.bb10
2 files changed, 21 insertions, 0 deletions
diff --git a/recipes/gpe-soundbite/files/makefile-fix.patch b/recipes/gpe-soundbite/files/makefile-fix.patch
new file mode 100644
index 0000000000..c2f14d17d7
--- /dev/null
+++ b/recipes/gpe-soundbite/files/makefile-fix.patch
@@ -0,0 +1,11 @@
+--- /tmp/Makefile 2006-07-26 10:51:15.000000000 +0200
++++ gpe-soundbite-1.0.6/Makefile 2006-07-26 10:52:02.924411000 +0200
+@@ -38,7 +38,7 @@
+ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS)
+
+ install-program: all $(PACKAGE)-play.desktop $(PACKAGE)-record.desktop
+- install -Ds $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install -D -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ install -D $(PACKAGE)-play $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)-play
+ install -D $(PACKAGE)-record $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)-record
+ mkdir -p $(DESTDIR)$(PREFIX)/share/applications
diff --git a/recipes/gpe-soundbite/gpe-soundbite_1.0.6.bb b/recipes/gpe-soundbite/gpe-soundbite_1.0.6.bb
new file mode 100644
index 0000000000..5297d3250d
--- /dev/null
+++ b/recipes/gpe-soundbite/gpe-soundbite_1.0.6.bb
@@ -0,0 +1,10 @@
+LICENSE = "GPL"
+inherit gpe pkgconfig
+
+SRC_URI += "file://makefile-fix.patch;patch=1"
+
+DESCRIPTION = "GPE audio Recorder"
+DEPENDS = "gtk+ libgpewidget libglade libgsm gpe-soundserver"
+SECTION = "gpe/multimedia"
+PRIORITY = "optional"
+LDFLAGS_append = " -Wl,--export-dynamic"