aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-today/gpe-today_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpe-today/gpe-today_svn.bb')
-rw-r--r--recipes/gpe-today/gpe-today_svn.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/gpe-today/gpe-today_svn.bb b/recipes/gpe-today/gpe-today_svn.bb
new file mode 100644
index 0000000000..329e2271ea
--- /dev/null
+++ b/recipes/gpe-today/gpe-today_svn.bb
@@ -0,0 +1,24 @@
+SECTION = "gpe"
+PRIORITY = "optional"
+DEPENDS = "gtk+ libxrandr libxsettings libxsettings-client libgpewidget libdisplaymigration libeventdb libgpepimc libtododb"
+PV = "0.11+svn-${SRCDATE}"
+PR = "r0"
+
+inherit gpe
+
+SRC_URI = "${GPE_SVN} \
+ file://Makefile.dpkg_ipkg \
+ file://Makefile.translation"
+
+S = "${WORKDIR}/${PN}"
+
+
+do_compile () {
+ sed -i 's:CVSBUILD = yes:CVSBUILD = no:' Makefile
+ mkdir -p build
+ cp ${WORKDIR}/Makefile.* build/
+ oe_runmake PREFIX=${prefix}
+ oe_runmake all-desktop PREFIX=${prefix}
+}
+
+DEFAULT_PREFERENCE = "-1"