aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpephone/soundserver_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpephone/soundserver_1.0.bb')
-rw-r--r--recipes/gpephone/soundserver_1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/gpephone/soundserver_1.0.bb b/recipes/gpephone/soundserver_1.0.bb
new file mode 100644
index 0000000000..5309ea2e82
--- /dev/null
+++ b/recipes/gpephone/soundserver_1.0.bb
@@ -0,0 +1,24 @@
+LICENSE = "LiPS"
+DESCRIPTION = "Cellphone alarm daemon"
+SECTION = "gpe"
+PRIORITY = "optional"
+PR = "r2"
+
+DEPENDS = "glib-2.0 libiac gstreamer"
+
+GPE_TARBALL_SUFFIX = "bz2"
+inherit gpephone autotools
+
+EXTRA_OECONF="--disable-osc8k"
+
+LDFLAGS += " -L${STAGING_LIBDIR}"
+
+do_configure () {
+ export PKG_CONFIG=${STAGING_BINDIR_NATIVE}/pkg-config
+ oe_runconf
+}
+
+do_configure_prepend () {
+ export PKG_CONFIG=${STAGING_BINDIR_NATIVE}/pkg-config
+ autoreconf
+}