summaryrefslogtreecommitdiffstats
path: root/recipes/gphoto2/ptp-gadget_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gphoto2/ptp-gadget_git.bb')
-rw-r--r--recipes/gphoto2/ptp-gadget_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gphoto2/ptp-gadget_git.bb b/recipes/gphoto2/ptp-gadget_git.bb
new file mode 100644
index 0000000000..edd08cdf21
--- /dev/null
+++ b/recipes/gphoto2/ptp-gadget_git.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "This is a device-side implementation of the PTP (Picture Transfer Protocol)"
+LICENSE = "GPLv3"
+
+DEPENDS = "virtual/kernel"
+RDEPENDS = "imagemagick"
+
+PV = "1.1"
+PR_append = "+gitr${SRCREV}"
+
+SRCREV = "ef7ef29b5cdcf8630c901362a66905b956242e0d"
+SRC_URI = "git://git.denx.de/ptp-gadget.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+do_compile () {
+ export CPPFLAGS="${CPPFLAGS} ${CFLAGS}"
+ sed -i -e 's:pthread:pthread ${LDFLAGS}:' Makefile
+ oe_runmake KERNEL_SRC=${STAGING_KERNEL_DIR} CROSS_COMPILE=${TARGET_PREFIX}
+}
+
+do_install () {
+ sed -i -e s:local/::g Makefile
+ # "/usr/bin" is hardcoded in the makefile
+ install -d ${D}/usr/bin
+ oe_runmake install DESTDIR="${D}"
+}
+
+#Need specific kernel headers
+PACKAGE_ARCH = "${MACHINE_ARCH}"