aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpsbabel/gpsbabel_1.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gpsbabel/gpsbabel_1.2.5.bb')
-rw-r--r--recipes/gpsbabel/gpsbabel_1.2.5.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/gpsbabel/gpsbabel_1.2.5.bb b/recipes/gpsbabel/gpsbabel_1.2.5.bb
new file mode 100644
index 0000000000..987b000f10
--- /dev/null
+++ b/recipes/gpsbabel/gpsbabel_1.2.5.bb
@@ -0,0 +1,20 @@
+SECTION = "console/utils"
+DESCRIPTION = "GPS data converter"
+DEPENDS = "expat libusb"
+HOMEPAGE = "http://gpsbabel.sf.net"
+LICENSE = "GPL"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gpsbabel/gpsbabel-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_compile () {
+ oe_runmake EXTRA_CFLAGS="-I${STAGING_INCDIR} -L${STAGING_LIBDIR}"
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0744 gpsbabel ${D}${bindir}
+}