aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gputty/gputty_0.9.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gputty/gputty_0.9.8.bb')
-rw-r--r--recipes/gputty/gputty_0.9.8.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/gputty/gputty_0.9.8.bb b/recipes/gputty/gputty_0.9.8.bb
new file mode 100644
index 0000000000..5e1ed06357
--- /dev/null
+++ b/recipes/gputty/gputty_0.9.8.bb
@@ -0,0 +1,27 @@
+# OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "GPuTTY is a PuTTY clone using the Gnome environment"
+HOMEPAGE = "http://www.defora.org/index.php?page=gputty"
+LICENSE = "GPL"
+SECTION = "network"
+PR = "r0"
+
+SRC_URI = "http://people.defora.org/~khorben/projects/gputty/gputty-${PV}.tar.gz \
+ file://gputty"
+
+do_compile() {
+ oe_runmake -C src
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ oe_runmake -C src BINDIR="${bindir}" DESTDIR="${D}" install
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${WORKDIR}/gputty ${D}${sysconfdir}/
+}
+
+# Save the configuration file in the package
+FILES_${PN} += " /etc/gputty"
+